summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2024-06-28 12:02:52 +0200
committerGuilhem Saurel2024-06-28 12:02:52 +0200
commit1d8894340c1f9d3e893a977575b399746196c6e9 (patch)
tree5e2d65dd2063ebe3752c30315b0bbd0ef71f6cff
parent311494085e4bbb745dced055347e0dab6a4fe468 (diff)
downloadaur-hpp-statistics-git.tar.gz
v5.0.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD47
3 files changed, 37 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65e8df9f507a..618d1070ffef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = hpp-statistics-git
pkgdesc = This package is part of the HPP software and provides a few tools for basic statistics. Devel branch.
- pkgver = 1.1.r58.fe1a714
+ pkgver = 5.0.0.r174.3114940
pkgrel = 1
url = https://github.com/humanoid-path-planner/hpp-statistics
arch = i686
arch = x86_64
- license = GPL3
+ license = BSD-2-Clause
makedepends = cmake
makedepends = git
- depends = hpp-util-git
- optdepends = doxygen
+ makedepends = doxygen
+ makedepends = boost
+ depends = boost-libs
+ depends = gcc-libs
+ depends = glibc
+ depends = hpp-util
provides = hpp-statistics
conflicts = hpp-statistics
- source = hpp-statistics::git://github.com/humanoid-path-planner/hpp-statistics.git
- md5sums = SKIP
+ source = hpp-statistics::git+https://github.com/humanoid-path-planner/hpp-statistics.git
+ sha256sums = SKIP
pkgname = hpp-statistics-git
-
diff --git a/.gitignore b/.gitignore
index c9a2611a0f0b..261acd5a12ad 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
hpp-statistics
pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index e66cb50e371e..191b8dfcd1db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,45 @@
-# Maintainer: Guilhem Saurel <saurel@laas.fr>
+# Maintainer: Guilhem Saurel <guilhem.saurel@laas.fr>
+_org='humanoid-path-planner'
_pkgname=hpp-statistics
-_pkgver=1.1
-pkgname=${_pkgname}-git
-pkgver=1.1.r58.fe1a714
+_pkgver=5.0.0
+pkgname="$_pkgname-git"
+pkgver=5.0.0.r174.3114940
pkgrel=1
pkgdesc="This package is part of the HPP software and provides a few tools for basic statistics. Devel branch."
arch=('i686' 'x86_64')
-url="https://github.com/humanoid-path-planner/$_pkgname"
-license=('GPL3')
-depends=('hpp-util-git')
-makedepends=('cmake' 'git')
-optdepends=('doxygen')
+url="https://github.com/$_org/$_pkgname"
+license=('BSD-2-Clause')
+depends=('boost-libs' 'gcc-libs' 'glibc' 'hpp-util')
+makedepends=('cmake' 'git' 'doxygen' 'boost')
conflicts=($_pkgname)
provides=($_pkgname)
-source=("$_pkgname"::"git://github.com/humanoid-path-planner/$_pkgname.git")
-md5sums=('SKIP')
+source=("$_pkgname"::"git+$url.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- echo "$_pkgver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ echo "$_pkgver.r$(git -C "$_pkgname" rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$_pkgname"
- git submodule update --init
- git checkout devel
+ git -C "$_pkgname" checkout devel
+ git -C "$_pkgname" submodule update --init --recursive
}
build() {
- cd "$_pkgname"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib .
- make
+ cmake -B build -S $_pkgname \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_DOCUMENTATION=ON \
+ -Wno-dev
+ cmake --build build
+}
+
+check() {
+ cmake --build build -t test
}
package() {
- cd "$_pkgname"
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" cmake --build build -t install
+ install -Dm644 "$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}