summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAqeel Akber2016-07-05 15:10:18 +1000
committerAqeel Akber2016-07-05 15:10:18 +1000
commitb75bcfafd1b9f694f4d93f1c96ba5a4712d96be6 (patch)
tree344d1323057ee92ccf8abde8cf07c4ee13f0b5a5
downloadaur-hsa-runtime-git.tar.gz
HSA Runtime 1.0.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5c9743c30ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hsa-runtime-git
+ pkgdesc = AMD Hetrogeneous System Architecture Runtime
+ pkgver = 1.0.3.1.gfa0ef7e
+ pkgrel = 1
+ url = https://github.com/HSAFoundation/HSA-Runtime-AMD
+ arch = x86_64
+ license = custom:AMD
+ provides = hsa-runtime
+ conflicts = hsa-runtime
+ source = hsa-runtime::git+https://github.com/HSAFoundation/HSA-Runtime-AMD
+ md5sums = SKIP
+
+pkgname = hsa-runtime-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2e6548e1738
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Aqeel Akber <self@aqeelakber.com>
+pkgname=hsa-runtime-git
+pkgver=1.0.3.1.gfa0ef7e
+pkgrel=1
+pkgdesc="AMD Hetrogeneous System Architecture Runtime"
+arch=('x86_64')
+url="https://github.com/HSAFoundation/HSA-Runtime-AMD"
+license=('custom:AMD')
+provides=('hsa-runtime')
+conflicts=('hsa-runtime')
+source=(hsa-runtime::git+https://github.com/HSAFoundation/HSA-Runtime-AMD)
+md5sums=('SKIP')
+
+
+pkgver(){
+ cd "$srcdir/hsa-runtime"
+ git describe --long --tags | sed 's/release-v//;s/f//;s/-/./;s/-/./'
+}
+
+package() {
+ #cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/hsa-runtime"
+ install -DTm 755 "LICENSE.txt" "$pkgdir/usr/share/licenses/hsa-runtime/LICENSE"
+ install -DTm 755 "README.md" "$pkgdir/opt/hsa/README.md"
+
+ cp -dr --no-preserve="ownership" "lib" "$pkgdir/opt/hsa/lib"
+ cp -dr --no-preserve="ownership" "include" "$pkgdir/opt/hsa/include"
+ cp -dr --no-preserve="ownership" "sample" "$pkgdir/opt/hsa/sample"
+}
+
+# vim:set ts=2 sw=2 et: