summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathas2015-06-09 23:05:22 -0300
committerJonathas2015-06-09 23:05:22 -0300
commit1eef4dd7785fad2aa61964a94f4d17ac25c3382c (patch)
treecc7990e68c6d92bf792108d493e28a657514aa02
downloadaur-htmlcr.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0af69d44e735
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = htmlcr
+ pkgdesc = htmlcrunch speeds up your HTML pages by removing things that are ignored by browsers anyway, such as superflous blanks, line feeds and comments
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = http://www.sourcefiles.org/Miscellaneous/htmlcr-0.8.1-src.zip.shtml
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ depends = unzip
+ source = http://www.sourcefiles.org/Miscellaneous/htmlcr-0.8.1-src.zip
+ md5sums = 7ede46804d75ab1d8c368f1e343b3d47
+
+pkgname = htmlcr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f679ffe755e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jon Ribeiro <contact@jonathas.com>
+pkgname=htmlcr
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="htmlcrunch speeds up your HTML pages by removing things that are ignored by browsers anyway, such as superflous blanks, line feeds and comments"
+arch=('i686' 'x86_64')
+url="http://www.sourcefiles.org/Miscellaneous/htmlcr-0.8.1-src.zip.shtml"
+license=('GPL')
+depends=('unzip')
+makedepends=('gcc')
+source=(http://www.sourcefiles.org/Miscellaneous/$pkgname-$pkgver-src.zip)
+md5sums=('7ede46804d75ab1d8c368f1e343b3d47')
+
+package() {
+ cd $startdir/src/
+ gcc htmlcr.c -o htmlcr
+ cd $startdir/pkg
+ mkdir -p usr/bin
+ cp $startdir/src/htmlcr $startdir/pkg/usr/bin/
+}
+
+