summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordtluna2019-03-30 15:54:42 +0300
committerdtluna2019-03-30 15:54:42 +0300
commitf547eaf73aa3dd1517b0d5769fc93a6ee2e8dd18 (patch)
tree7bc711314c0b0d44073152776c7476a7cd12b0db
downloadaur-htmltui-bin.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..324035317a14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = htmltui-bin
+ pkgdesc = A terminal UI utility to view HTML
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://git.dtluna.net/dtluna/htmltui
+ arch = x86_64
+ arch = i686
+ license = custom:WTFPL
+ conflicts = htmltui
+ source_x86_64 = htmltui-bin_1.4.0_linux_x86_64.zip::https://git.dtluna.net/attachments/d63a2ab5-af4d-4177-a9c5-c3c371740c78
+ sha256sums_x86_64 = e30cd6dc57eb480834674c17b4e228bbe5dc20525720d18efc5615bbb9f4552a
+ source_i686 = htmltui-bin_1.4.0_linux_i686.zip::https://git.dtluna.net/attachments/735470e9-62d3-4c0a-91b8-843d87440d7d
+ sha256sums_i686 = f22283fac36c7b42c3311ec758f6194f1f29dbe6520e6948b3902fc3a1cddf8e
+
+pkgname = htmltui-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31d27563afeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3bcc111660a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: dtluna <dtluna at waifu dot club>
+
+_pkgname_base='htmltui'
+pkgname="${_pkgname_base}-bin"
+pkgver='1.4.0'
+pkgrel=1
+pkgdesc='A terminal UI utility to view HTML'
+url='https://git.dtluna.net/dtluna/htmltui'
+arch=('x86_64' 'i686')
+license=('custom:WTFPL')
+
+depends=()
+makedepends=()
+optdepends=()
+
+conflicts=("${_pkgname_base}")
+
+source_x86_64=("${pkgname}_${pkgver}_linux_x86_64.zip::https://git.dtluna.net/attachments/d63a2ab5-af4d-4177-a9c5-c3c371740c78")
+source_i686=("${pkgname}_${pkgver}_linux_i686.zip::https://git.dtluna.net/attachments/735470e9-62d3-4c0a-91b8-843d87440d7d")
+
+sha256sums_x86_64=('e30cd6dc57eb480834674c17b4e228bbe5dc20525720d18efc5615bbb9f4552a')
+sha256sums_i686=('f22283fac36c7b42c3311ec758f6194f1f29dbe6520e6948b3902fc3a1cddf8e')
+
+
+package() {
+ # Bin
+ rm -f "${pkgdir}/usr/bin/${_pkgname_base}"
+ install -Dm755 "${srcdir}/${_pkgname_base}" "${pkgdir}/usr/bin/${_pkgname_base}"
+
+ # License
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname_base}/LICENSE"
+}
+