summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEden Rose2018-04-25 02:59:13 -0400
committerEden Rose2018-04-25 02:59:13 -0400
commit9358ee32d2f56f288ec7ad3e4d6d9ba6221dbe33 (patch)
treea9e1dad50f5e8d2da66362cf7b65d48b8d2cc77b
downloadaur-htop-temperature-git.tar.gz
Added Temperature Support to HTOP*(upstream)
-rw-r--r--.SRCINFO30
-rwxr-xr-xPKGBUILD67
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd20f51f4998
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = htop-temperature-git
+ pkgdesc = Interactive text-mode process viewer
+ pkgver = 1057.04cc193
+ pkgrel = 1
+ url = https://github.com/hishamhm/htop
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
+ license = GPL
+ makedepends = git
+ makedepends = python2
+ depends = ncurses
+ depends = libnl
+ depends = lm_sensors
+ optdepends = lsof: list open files for running process
+ optdepends = strace: attach to running process
+ provides = htop
+ conflicts = htop
+ options = !emptydirs
+ source = git+https://github.com/hishamhm/htop.git
+ source = 0001-fix-option-string.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/0001-fix-option-string.patch?h=packages/htop
+ source = htop-temperature.patch::https://aur.archlinux.org/cgit/aur.git/plain/htop-temperature.patch?h=htop-temperature
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = a4c9dfbc3c2f7e08904656b53b9c08d19014cf6238fb75f1ed5ecbef2905964c
+
+pkgname = htop-temperature-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..f12e1871cdf3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Eden Rose <eenov1988 (at) gmail (dot) com>
+# Maintainer(htop-git): Yardena Cohen <yardenack at gmail dot com>
+# Maintainer: Maxim Kurnosenko <asusx2@mail.ru>
+# Contributor: Blair Bonnett <blair.bonnett at gmail dot com>
+
+
+gitname=htop
+pkgname=${gitname}-temperature-git
+pkgver=1057.04cc193
+pkgrel=1
+pkgdesc="Interactive text-mode process viewer"
+url="https://github.com/hishamhm/${gitname}"
+license=('GPL')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
+depends=('ncurses' 'libnl' 'lm_sensors')
+makedepends=('git' 'python2')
+optdepends=('lsof: list open files for running process'
+ 'strace: attach to running process')
+provides=('htop')
+conflicts=('htop')
+options=('!emptydirs')
+source=("git+${url}.git"
+"0001-fix-option-string.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/0001-fix-option-string.patch?h=packages/htop"
+"htop-temperature.patch::https://aur.archlinux.org/cgit/aur.git/plain/htop-temperature.patch?h=htop-temperature")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'a4c9dfbc3c2f7e08904656b53b9c08d19014cf6238fb75f1ed5ecbef2905964c')
+
+pkgver() {
+ cd "${srcdir}/${gitname}"
+ local ver="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ printf "%s" "${ver//-/.}"
+}
+
+prepare() {
+ cd "${srcdir}/${gitname}"
+
+ patch -Np1 < "$srcdir"/0001-fix-option-string.patch
+
+ # Add CPU temperature patch.
+ patch -Np1 < "$srcdir"/htop-temperature.patch
+
+ CC="gcc"
+ CXX="g++"
+
+ ./autogen.sh
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-cgroup \
+ --enable-delayacct \
+ --enable-unicode \
+ --enable-openvz \
+ --enable-vserver \
+ --enable-cgroup
+}
+
+build() {
+ cd "${srcdir}/${gitname}"
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/${gitname}"
+ make DESTDIR="${pkgdir}" install
+}