summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2016-10-07 19:30:51 +0800
committerJingbei Li2016-10-07 19:30:51 +0800
commitdefdf7dcfde0f946901a255adb346ef3bd60dc67 (patch)
treef21b0fff363d0e0774992c0bc1f348da89146c26
parent1c8ebe96f2e0370991802bbaa1dd3e7483b96668 (diff)
downloadaur-hts.tar.gz
upgrade to 2.3
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD84
3 files changed, 38 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1e57cb855ec..772a43f39d68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Oct 7 11:30:48 UTC 2016
pkgbase = hts
pkgdesc = Modified version (patch) of the Hidden Markov Model Toolkit (htk).
- pkgver = 2.2
- pkgrel = 4
+ pkgver = 2.3
+ pkgrel = 1
url = http://hts.sp.nitech.ac.jp/
arch = i686
arch = x86_64
license = custom
- makedepends = wget
makedepends = patch
depends = libx11
conflicts = htk
- source = http://hts.sp.nitech.ac.jp/archives/2.2/HTS-2.2_for_HTK-3.4.1.tar.bz2
- md5sums = 76b7674a01f1edfeb5b4bbca4f5e39a2
+ source = http://hts.sp.nitech.ac.jp/archives/2.3/HTS-2.3_for_HTK-3.4.1.tar.bz2
+ source = file://HTK-3.4.1.tar.gz
+ source = file://HDecode-3.4.1.tar.gz
+ md5sums = cb8e68a2ea2320b0e8fb519f86fa429d
+ md5sums = b3fc12006b0af12f59cd573c07aa4c1d
+ md5sums = 4e332a7fea6db58751cec878b80c3575
pkgname = hts
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..949722cd6307
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar*
+*/
diff --git a/PKGBUILD b/PKGBUILD
index ff00d790215c..36e9aa7e96c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,73 +1,41 @@
-# Maintainer: Moritz Maxeiner <moritz@ucworks.org>
+# Maintainer: Jingbei Li <i@jingbei.li>
pkgname=hts
-pkgver=2.2
+pkgver=2.3
_htkver=3.4.1
-pkgrel=4
+pkgrel=1
pkgdesc="Modified version (patch) of the Hidden Markov Model Toolkit (htk)."
arch=('i686' 'x86_64')
url="http://hts.sp.nitech.ac.jp/"
license=('custom')
depends=('libx11')
-makedepends=('wget' 'patch')
+makedepends=('patch')
conflicts=(htk)
-source=(http://hts.sp.nitech.ac.jp/archives/$pkgver/HTS-${pkgver}_for_HTK-$_htkver.tar.bz2)
-md5sums=('76b7674a01f1edfeb5b4bbca4f5e39a2')
+source=(http://hts.sp.nitech.ac.jp/archives/$pkgver/HTS-${pkgver}_for_HTK-$_htkver.tar.bz2
+file://HTK-$_htkver.tar.gz # Download it yourself from http://htk.eng.cam.ac.uk/
+file://HDecode-$_htkver.tar.gz # Download it yourself from http://htk.eng.cam.ac.uk/
+)
+md5sums=('cb8e68a2ea2320b0e8fb519f86fa429d'
+'b3fc12006b0af12f59cd573c07aa4c1d'
+'4e332a7fea6db58751cec878b80c3575')
build() {
- cd $srcdir/../
+ cd $srcdir/htk
+ echo "Patching HTK source code to HTS..."
+ patch -p1 -t -d . < "./../HTS-${pkgver}_for_HTK-$_htkver.patch"
- echo "Please put the necessary files 'HTK-$_htkver.tar.gz' and 'HDecode-$_htkver.tar.gz' in the folder $srcdir/../ and press [ENTER]."
- echo -n "If you do not have them, press [ENTER] and they will be downloaded for you..."
- read
- echo
-
- if [ ! -e HTK-$_htkver.tar.gz ] || [ ! -e HDecode-$_htkver.tar.gz ]; then
- # HTK account necessary to download HTK source code
- echo "You need an HTK account to download the source code HTS uses."
- echo "You can create such an account here: http://htk.eng.cam.ac.uk/register.shtml"
- echo "Please proceed only if you have one, the build will fail otherwise!"
- echo
- echo -n "Please enter your HTK username: "
- read username
- echo -n "Please enter your HTK password: "
- read password
-
- # Get the htk source code
- wget --user=$username --password=$password http://htk.eng.cam.ac.uk/ftp/software/HTK-$_htkver.tar.gz
- wget --user=$username --password=$password http://htk.eng.cam.ac.uk/ftp/software/hdecode/HDecode-$_htkver.tar.gz
- fi
-
- if ! (md5sum -c <<< "b3fc12006b0af12f59cd573c07aa4c1d HTK-$_htkver.tar.gz"); then
- echo "HTK md5sum wrong"
- return 1
- fi
- if ! (md5sum -c <<< "4e332a7fea6db58751cec878b80c3575 HDecode-$_htkver.tar.gz"); then
- echo "HDecode md5sum wrong"
- return 1
- fi
-
- cp HTK-$_htkver.tar.gz $srcdir/
- cp HDecode-$_htkver.tar.gz $srcdir/
- cd $srcdir
- bsdtar -xf HTK-$_htkver.tar.gz
- bsdtar -xf HDecode-$_htkver.tar.gz
- cd htk
- echo "Patching HTK source code to HTS..."
- patch -p1 -t -d . < "./../HTS-${pkgver}_for_HTK-$_htkver.patch"
-
- echo "Beginning build..."
- CFLAGS="${CFLAGS/-D_FORTIFY_SOURCE=2/}" ./configure --prefix=/usr
- make
+ echo "Beginning build..."
+ CFLAGS="${CFLAGS/-D_FORTIFY_SOURCE=2/} -DARCH=\'$CARCH\'" ./configure --prefix=/usr
+ make
}
package() {
- cd "$srcdir/htk"
- make prefix="$pkgdir/usr" install
-
- # The HTK license applying to the package
- install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE-HTK
- # The HDecode extension license
- install -D -m644 HTKLVRec/HDecode-license.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-HDecode
- # The HTS license applying to the patch
- install -D -m644 $srcdir/COPYING ${pkgdir}/usr/share/licenses/$pkgname/COPYING-HTS
+ cd "$srcdir/htk"
+ make prefix="$pkgdir/usr" install
+
+ # The HTK license applying to the package
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE-HTK
+ # The HDecode extension license
+ install -D -m644 HTKLVRec/HDecode-license.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-HDecode
+ # The HTS license applying to the patch
+ install -D -m644 $srcdir/COPYING ${pkgdir}/usr/share/licenses/$pkgname/COPYING-HTS
}