summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-08-11 12:40:20 +0100
committerAlexandros Theodotou2019-08-11 12:40:20 +0100
commitf2c8e2528dcef43a3bec7fd69820cec4eee06cee (patch)
treed2ce2c3f9e8d0ed2058d6a68fabfbd5043905843
parentb97e12336dd37a98654a307b4e63210b5e4a799c (diff)
downloadaur-hts-engine.tar.gz
use DESTDIR
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c06ca02d4844..db575906e587 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hts-engine
pkgdesc = Engine to synthesize speech waveform from HMMs trained by hts.
pkgver = 1.10
- pkgrel = 2
+ pkgrel = 3
url = http://hts-engine.sourceforge.net/
arch = i686
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = hts-engine
license = BSD
depends = glibc
options = staticlibs
- source = http://downloads.sourceforge.net/hts-engine/hts_engine_API-1.10.tar.gz
+ source = https://downloads.sourceforge.net/hts-engine/hts_engine_API-1.10.tar.gz
md5sums = 5626d1e2522659e93fb295f0b42339f5
sha256sums = e2132be5860d8fb4a460be766454cfd7c3e21cf67b509c48e1804feab14968f7
diff --git a/PKGBUILD b/PKGBUILD
index 07962cf8e60e..8bda8f64f1f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Moritz Maxeiner <moritz@ucworks.org>
+# Maintainer: Alexandros Theodotou <alex@zrythm.org>
+_tarball=hts_engine_API
pkgname=hts-engine
pkgver=1.10
-pkgrel=2
+pkgrel=3
pkgdesc="Engine to synthesize speech waveform from HMMs trained by hts."
arch=('i686' 'x86_64' 'armv7h')
url="http://hts-engine.sourceforge.net/"
license=('BSD')
depends=('glibc')
options=('staticlibs')
-source=(http://downloads.sourceforge.net/$pkgname/hts_engine_API-$pkgver.tar.gz)
+source=(https://downloads.sourceforge.net/$pkgname/$_tarball-$pkgver.tar.gz)
md5sums=('5626d1e2522659e93fb295f0b42339f5')
sha256sums=('e2132be5860d8fb4a460be766454cfd7c3e21cf67b509c48e1804feab14968f7')
build()
{
-
- cd "$srcdir/hts_engine_API-$pkgver"
+ cd "$srcdir/$_tarball-$pkgver"
./configure --prefix=/usr
make
}
package()
{
- cd "$srcdir/hts_engine_API-$pkgver"
- make prefix="$pkgdir/usr" install
+ cd "$srcdir/$_tarball-$pkgver"
+ make DESTDIR="$pkgdir" prefix="/usr" install
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}