summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-06-03 23:15:53 +0200
committeranthraxx2016-06-03 23:15:53 +0200
commitf0ae81fcabc29b14e1277f4a6a1b4a0df6e6f4ed (patch)
treeab56c3c7c92f219738f7c62e530e3a44c522dfbb
downloadaur-httping-git.tar.gz
addpkg: httping-git 2.4.289.b1521a6-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fa232d5f972
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Jun 3 21:15:53 UTC 2016
+pkgbase = httping-git
+ pkgdesc = A ping-like tool for http-requests
+ pkgver = 2.4.289.b1521a6
+ pkgrel = 1
+ url = https://www.vanheusden.com/httping/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = openssl
+ depends = ncurses
+ depends = fftw
+ provides = httping
+ conflicts = httping
+ source = httping-git::git+https://github.com/flok99/httping
+ sha512sums = SKIP
+
+pkgname = httping-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe7841074772
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+
+pkgname=httping-git
+pkgver=2.4.289.b1521a6
+pkgrel=1
+pkgdesc='A ping-like tool for http-requests'
+url='https://www.vanheusden.com/httping/'
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('openssl' 'ncurses' 'fftw')
+makedepends=('git')
+provides=('httping')
+conflicts=('httping')
+source=(${pkgname}::git+https://github.com/flok99/httping)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|sed -r 's|v?(.+)|\1|')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname}
+ ./configure
+ make
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: