summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlizaifang2015-06-09 09:06:55 +0800
committerlizaifang2015-06-09 09:06:55 +0800
commit3c56cdc8ffa0f64838942a4dda33034f6960e4e0 (patch)
tree62f0a4949e88b4807c5424d95e8bf747a9b7661d
downloadaur-httpsqs.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rwxr-xr-xhttpsqs46
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e99ea9690ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = httpsqs
+ pkgdesc = HTTP Simple Queue Service, message queue based on HTTP GET/POST protocol.
+ pkgver = 1.7
+ pkgrel = 1
+ url = http://code.google.com/p/httpsqs
+ arch = i686
+ arch = x64
+ license = BSD
+ depends = libevent
+ depends = tokyocabinet
+ source = http://httpsqs.googlecode.com/files/httpsqs-1.7.tar.gz
+ source = httpsqs
+ md5sums = 2e5a71a5ed04c30efeab9939ca39a786
+ md5sums = 66f5a727b0b1d7ddb44541a17953c58f
+
+pkgname = httpsqs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fef989f4dcd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: MkFly <mmkfly@gmail.com>
+# Contributor: Igor Nemilentsev <trezorg@gmail.com>
+
+pkgname=httpsqs
+pkgver=1.7
+pkgrel=1
+pkgdesc='HTTP Simple Queue Service, message queue based on HTTP GET/POST protocol.'
+arch=('i686' 'x64')
+url='http://code.google.com/p/httpsqs'
+license=('BSD')
+depends=('libevent' 'tokyocabinet')
+source=(http://httpsqs.googlecode.com/files/httpsqs-1.7.tar.gz httpsqs)
+md5sums=('2e5a71a5ed04c30efeab9939ca39a786'
+ '66f5a727b0b1d7ddb44541a17953c58f'
+)
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ mkdir -p ${pkgdir}/usr/bin || return 1
+ mkdir -p ${pkgdir}/etc/rc.d || return 1
+ cp -v ${srcdir}/httpsqs ${pkgdir}/etc/rc.d/httpsqs
+ make DESTDIR=${pkgdir} install || return 1
+} \ No newline at end of file
diff --git a/httpsqs b/httpsqs
new file mode 100755
index 000000000000..d8b023295a77
--- /dev/null
+++ b/httpsqs
@@ -0,0 +1,46 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+DAEMON="httpsqs"
+DAEMON_DESC="Simple Queue Service"
+#ARGS="-x /home/db/httpsqs"
+ARGS="-x /tmp/httpsqs"
+PIDFILE=/tmp/httpsqs.pid
+PID=`cat $PIDFILE 2>/dev/null`
+
+#[ -r /etc/conf.d/$DAEMON ] && . /etc/conf.d/$DAEMON
+
+case "$1" in
+ start)
+ stat_busy "Starting $DAEMON_DESC"
+ [ -z "$PID" ] && $DAEMON $ARGS & >/dev/null
+ if [ $? = 0 ]; then
+ add_daemon $DAEMON
+ stat_done
+ else
+ stat_fail
+ exit 1
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping $DAEMON_DESC"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? = 0 ]; then
+ rm_daemon $DAEMON
+ stat_done
+ else
+ stat_fail
+ exit 1
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+