summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonne Haß2019-01-13 20:22:49 +0100
committerJonne Haß2019-01-13 20:22:49 +0100
commitc49ed1a997a9be5902be3cfddc5ccfd0955fa148 (patch)
treed8e47354d670724173a6542c312c3102d286b1d2
parent3b8718082ecc4465da9141333d927abd94927912 (diff)
downloadaur-hub-git.tar.gz
hub-git: rebase on community package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c66a649f110..111e0c93181e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = hub-git
pkgdesc = cli interface for Github
- pkgver = v2.4.0.r10.g98f153f3
+ pkgver = v2.7.0.r31.gddf0d825
pkgrel = 1
url = https://hub.github.com
arch = x86_64
arch = i686
license = MIT
makedepends = go
- makedepends = groff
- makedepends = ruby-bundler
depends = git
provides = hub
conflicts = hub
diff --git a/PKGBUILD b/PKGBUILD
index 30a89290404d..54a8551582de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonne Haß <me@jhass.eu>
pkgname=hub-git
-pkgver=v2.4.0.r10.g98f153f3
+pkgver=v2.7.0.r31.gddf0d825
pkgrel=1
pkgdesc="cli interface for Github"
url="https://hub.github.com"
@@ -9,33 +9,37 @@ license=('MIT')
conflicts=('hub')
provides=('hub')
depends=('git')
-makedepends=('go' 'groff' 'ruby-bundler')
+makedepends=('go')
source=("git+https://github.com/github/hub.git")
sha256sums=('SKIP')
+prepare() {
+ cd "${pkgname/-git/}"
+ mkdir -p "$srcdir/src/github.com/github/hub"
+ cp -r . "$srcdir/src/github.com/github/hub"
+ rm -rf "$srcdir/src/github.com/github/hub/.git"
+ sed -i 's@.man-pages.stamp: bin/ronn@.man-pages.stamp:@;s@bin/ronn@ronn@' "$srcdir/src/github.com/github/hub/Makefile"
+}
+
pkgver() {
cd "${pkgname/-git/}"
git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname/-git/}"
+ cd "$srcdir/src/github.com/github/hub"
export GOPATH="$srcdir"
- go get -fix -v -x github.com/github/hub
- script/bootstrap
- make -j1 bin/hub man-pages
+ make -j1
+ make -j1 man-pages
}
package() {
- cd "$srcdir/${pkgname/-git/}"
+ cd "$srcdir/src/github.com/github/hub"
- install -Dm755 bin/hub "$pkgdir/usr/bin/hub"
+ make PREFIX="$pkgdir/usr" install
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname/-git/}/LICENSE"
install -Dm644 etc/hub.bash_completion.sh "$pkgdir/usr/share/bash-completion/completions/hub"
install -Dm644 etc/hub.zsh_completion "$pkgdir/usr/share/zsh/site-functions/_hub"
install -Dm644 etc/hub.fish_completion "$pkgdir/usr/share/fish/vendor_completions.d/hub.fish"
- for manpage in share/man/man1/hub.1 share/man/man1/hub-*.1; do
- install -Dm644 $manpage "$pkgdir/usr/share/man/man1/$(basename $manpage)"
- done
}