summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAonrud2023-04-16 16:55:23 +0100
committerAonrud2023-04-16 16:55:23 +0100
commite74cb510cb7198172d9d3a657819dbdf0b2d975b (patch)
treeae10dcae5d705892cc1a22d6c6f3e157b2f99fcb
downloadaur-hunspell-ga.tar.gz
initial commit: add PGKBUILD and .SRCINFO
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..983b049a66de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hunspell-ga
+ pkgdesc = Irish (Gaeilge) dictionary for Hunspell
+ pkgver = 5.1
+ pkgrel = 1
+ url = https://github.com/kscanne/gaelspell
+ arch = any
+ license = GPL2
+ license = FDL1.2
+ depends = hunspell
+ source = hunspell-ga-5.1.zip::https://github.com/kscanne/gaelspell/releases/download/v5.1/hunspell-ga-5.1.zip
+ md5sums = 73f4e6c8cb9fac405191633b7f3ae2ec
+
+pkgname = hunspell-ga
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..634800118130
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=hunspell-ga
+pkgver=5.1
+pkgrel=1
+pkgdesc='Irish (Gaeilge) dictionary for Hunspell'
+arch=('any')
+url='https://github.com/kscanne/gaelspell'
+license=('GPL2' 'FDL1.2')
+depends=('hunspell')
+source=(
+"$pkgname-$pkgver.zip::https://github.com/kscanne/gaelspell/releases/download/v${pkgver}/${pkgname}-${pkgver}.zip")
+md5sums=('73f4e6c8cb9fac405191633b7f3ae2ec')
+
+package() {
+ cd "$srcdir"
+
+ install -dm755 "${pkgdir}"/usr/share/hunspell
+ cp -p ga_IE.aff "${pkgdir}"/usr/share/hunspell/ga_IE.aff
+ cp -p ga_IE.dic "${pkgdir}"/usr/share/hunspell/ga_IE.dic
+
+ #myspell
+ install -dm755 "${pkgdir}"/usr/share/myspell/dicts
+ pushd "${pkgdir}"/usr/share/myspell/dicts
+ for file in "${pkgdir}"/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/"$(basename "${file}")" .
+ done
+ popd
+
+ #docs
+ install -dm755 ${pkgdir}/usr/share/doc/${pkgname}
+ install -m644 README_ga_IE.txt ${pkgdir}/usr/share/doc/${pkgname}/
+}
+