summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:24:01 +0200
committerKevin Brubeck Unhammer2015-07-14 10:24:01 +0200
commit651765a8e8a7695153df2fad89e7de5dc5ece067 (patch)
tree51ecb3b1620a37f39ed0f5346059ac66e2080975
downloadaur-hunspell-sme.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8e46ab2f748
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hunspell-sme
+ pkgdesc = Northern Sámi (se/sme) dictionary for Hunspell
+ pkgver = 1.0beta9.20110318
+ pkgrel = 1
+ url = http://www.divvun.no/en/userdocs/X-spell/install_linux.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = hunspell
+ source = http://divvun.no/static_files/hunspell-smi.tar.gz
+ md5sums = 0e568da241f65dbe2771c2b314aae319
+
+pkgname = hunspell-sme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e67a2607a155
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@gmail.com>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@gmail.com>
+
+pkgname=hunspell-sme
+pkgver=1.0beta9.20110318
+pkgrel=1
+pkgdesc="Northern Sámi (se/sme) dictionary for Hunspell"
+arch=('i686' 'x86_64')
+url="http://www.divvun.no/en/userdocs/X-spell/install_linux.html"
+license=('GPL')
+depends=('hunspell')
+# Can't find a static link to the file of this pkgver, so this PKGBUILD might eventually need changes
+source=(http://divvun.no/static_files/hunspell-smi.tar.gz)
+md5sums=('0e568da241f65dbe2771c2b314aae319')
+
+build() {
+ cd $srcdir/hunspell-smi-$pkgver/
+ make -f Makefile.smi || return 1
+ make DESTDIR=$startdir/pkg -f Makefile.smi install || return 1
+
+ # Ensure that LibreOffice finds them:
+ mkdir -p $startdir/pkg/usr/share/hunspell
+ ln -s $startdir/pkg/usr/share/myspell/dicts/se{,_NO,_SE,_FI}.{dic,aff} $startdir/pkg/usr/share/hunspell/
+
+ # Remove the dictionaries we don't need (separate packages for them):
+ rm -f $startdir/pkg/usr/share/myspell/dicts/smj{,_NO,_SE}.{dic,aff}
+ rm -f $startdir/pkg/usr/share/myspell/dicts/sma{,_NO,_SE}.{dic,aff}
+
+ # I believe dictionary.lst should be a user-configurable file, in
+ # any case it would get overwritten if new packages wanted to do the
+ # same thing, and the dictionaries seems to work without this:
+ rm -f $startdir/pkg/usr/share/myspell/dicts/dictionary.lst
+}