summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvheeze2018-11-12 18:51:41 +0700
committervheeze2018-11-12 18:51:41 +0700
commit52c0e05a5aff428a386ebecd4521f567fcfb3645 (patch)
tree2ef90ac51a4889e0f38d6c2615ba3d4b81290afe
downloadaur-hunspell-th.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6b193482528
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hunspell-th
+ pkgdesc = Thai hunspell dictionary
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/tafasu/aegisub-thai-dict
+ arch = any
+ license = LGPL2
+ makedepends = hunspell
+ optdepends = hunspell: the spell checking libraries and apps
+ source = https://github.com/tafasu/aegisub-thai-dict/archive/master.zip
+ sha256sums = 0e1e7081354669e8ee7158778099400a75a52528e067503fba0976d49cf83dbc
+
+pkgname = hunspell-th
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed5921e938e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Maintainer : vheeze at yandex dot com
+#From OpenOffice dictionary. Converted to UTF-8
+
+pkgname=hunspell-th
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Thai hunspell dictionary"
+arch=(any)
+url="https://github.com/tafasu/aegisub-thai-dict"
+license=('LGPL2')
+makedepends=('hunspell')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=("https://github.com/tafasu/aegisub-thai-dict/archive/master.zip")
+sha256sums=('0e1e7081354669e8ee7158778099400a75a52528e067503fba0976d49cf83dbc')
+
+package(){
+
+ #copy hunspell
+ cd "${srcdir}"
+ install -dm755 "${pkgdir}"/usr/share/hunspell
+ cp -p aegisub-thai-dict-master/th_TH.aff "${pkgdir}"/usr/share/hunspell/th_TH.aff
+ cp -p aegisub-thai-dict-master/th_TH.dic "${pkgdir}"/usr/share/hunspell/th_TH.dic
+
+
+
+ #myspell symlinks
+ install -dm755 "${pkgdir}"/usr/share/myspell/dicts
+ pushd "${pkgdir}"/usr/share/myspell/dicts
+ for file in "${pkgdir}"/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/"$(basename "${file}")" .
+ done
+ popd
+
+
+}