summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorg00dy222020-01-01 23:58:15 +0200
committerg00dy222020-01-01 23:58:15 +0200
commitda32b342700eb1883a2405b726c98494b3afe2d9 (patch)
tree5c85fea5397d84df9403dbd2105f99ba6893a6bd
parentb6ad81b59a571d2d62375b425db6bc78c36e0842 (diff)
downloadaur-da32b342700eb1883a2405b726c98494b3afe2d9.tar.gz
update to 4.8.0, src location changed to github
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ace656e3bd7a..5586df02a74e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = hunspell-uk
pkgdesc = Ukrainian spelling dictionary
- pkgver = 4.6.2
+ pkgver = 4.8.0
pkgrel = 1
- url = https://extensions.libreoffice.org/extensions/ukrainian-spelling-dictionary-and-thesaurus
+ url = https://github.com/brown-uk/dict_uk
arch = any
groups = dict-uk
license = MPL
optdepends = hunspell: the spell checking libraries and apps
- source = https://extensions.libreoffice.org/extensions/ukrainian-spelling-dictionary-and-thesaurus/4-6.2/@@download/file/dict-uk_ua-4.6.2.oxt
- sha256sums = 96271ded9729a0b91773cf582cd8dfeace56534a46041d74ed957f5e3e922fca
+ source = https://github.com/brown-uk/dict_uk/releases/download/v4.8.0/hunspell-uk_UA_4.8.0.zip
+ source = https://github.com/brown-uk/dict_uk/releases/download/v4.8.0/chrome_dict_uk-UA-4.8.0.zip
+ sha256sums = 1f6d20dd42611d0fe04c8960d448bb6f7b2d2ea404e8bb91ddbc17650eb69d48
+ sha256sums = 24dabd0ac63dcf12fdbbfc639cc70655c9d89114ec5fe13074a335675a0c716f
pkgname = hunspell-uk
diff --git a/PKGBUILD b/PKGBUILD
index 1326dcdd80d3..7cd56afd6d98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,32 @@
# Contributor: Rax Garfield <admin at dvizho.ks.ua>
pkgname=hunspell-uk
-pkgver=4.6.2
+pkgver=4.8.0
pkgrel=1
pkgdesc="Ukrainian spelling dictionary"
arch=('any')
-url='https://extensions.libreoffice.org/extensions/ukrainian-spelling-dictionary-and-thesaurus'
+url='https://github.com/brown-uk/dict_uk'
license=('MPL')
groups=('dict-uk')
optdepends=('hunspell: the spell checking libraries and apps')
-source=("https://extensions.libreoffice.org/extensions/ukrainian-spelling-dictionary-and-thesaurus/${pkgver/./-}/@@download/file/dict-uk_ua-$pkgver.oxt")
-sha256sums=('96271ded9729a0b91773cf582cd8dfeace56534a46041d74ed957f5e3e922fca')
+source=("https://github.com/brown-uk/dict_uk/releases/download/v4.8.0/hunspell-uk_UA_${pkgver}.zip"
+ "https://github.com/brown-uk/dict_uk/releases/download/v4.8.0/chrome_dict_uk-UA-${pkgver}.zip")
+sha256sums=('1f6d20dd42611d0fe04c8960d448bb6f7b2d2ea404e8bb91ddbc17650eb69d48'
+ '24dabd0ac63dcf12fdbbfc639cc70655c9d89114ec5fe13074a335675a0c716f')
package() {
- cd uk_UA
- install -dm755 ${pkgdir}/usr/share/hunspell
- install -m644 uk_UA.* ${pkgdir}/usr/share/hunspell
+ install -dm755 "$pkgdir"/usr/share/hunspell
+ install -m644 uk_UA.* "$pkgdir"/usr/share/hunspell
- # symlinks
+ # Install webengine dictionaries
+ install -d "$pkgdir"/usr/share/qt/qtwebengine_dictionaries
+ install -m644 uk-UA-3-0.bdic "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/uk_UA.bdic
+
+ # myspell symlinks
install -dm755 ${pkgdir}/usr/share/myspell/dicts
pushd ${pkgdir}/usr/share/myspell/dicts
for file in ${pkgdir}/usr/share/hunspell/*; do
ln -sv /usr/share/hunspell/$(basename ${file}) .
done
popd
-
- # docs
- install -dm755 ${pkgdir}/usr/share/doc/${pkgname}
- install -m644 README_uk_UA.txt ${pkgdir}/usr/share/doc/${pkgname}
}