summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorox55ff2024-01-27 00:12:23 +0300
committerox55ff2024-01-27 00:12:23 +0300
commitd6e8590fd064fc824b9b45d5607c1204bf25f56d (patch)
tree17109f17d69fe8bc0412900c074a829fd02a4815
downloadaur-hycov-git.tar.gz
Create PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fc51ba9df60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hycov-git
+ pkgdesc = Hyprland overview mode plugin, a new tile window workflow
+ pkgver = 0.34.0.1.r95.84b9f00
+ pkgrel = 1
+ url = https://github.com/DreamMaoMao/hycov
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = hyprland
+ provides = hycov
+ conflicts = hycov
+ source = git+https://github.com/DreamMaoMao/hycov.git
+ b2sums = SKIP
+
+pkgname = hycov-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f54a34f2c0e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: ox55ff
+
+pkgname=hycov-git
+pkgver=0.34.0.1.r95.84b9f00
+pkgrel=1
+pkgdesc="Hyprland overview mode plugin, a new tile window workflow"
+arch=(x86_64)
+url="https://github.com/DreamMaoMao/hycov"
+license=(MIT)
+depends=(
+ hyprland
+)
+makedepends=(
+ git
+ meson
+ ninja
+)
+provides=(hycov)
+conflicts=(hycov)
+source=("git+https://github.com/DreamMaoMao/hycov.git")
+b2sums=('SKIP')
+
+pkgver() {
+ git -C hycov describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+build() {
+ cd hycov
+
+ meson setup build \
+ --prefix /usr \
+ --buildtype release
+
+ meson compile -C build
+}
+
+package() {
+ cd hycov
+
+ meson install -C build \
+ --destdir "$pkgdir"
+}