summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2024-02-15 12:00:29 +0000
committerScore_Under2024-02-15 12:00:29 +0000
commit0dab230e355957eba830ad26a657b3e56f4b19eb (patch)
tree08014a86ad6d144f8f99cc6102f8b96dc806cf5b
parentfc67038ad0fcdabc793df0cd0cba0954b319d247 (diff)
downloadaur-0dab230e355957eba830ad26a657b3e56f4b19eb.tar.gz
Update for v652
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch13
3 files changed, 6 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c32a5203c914..6c6b1b4f86c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 561
+ pkgver = 562
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
arch = any
@@ -45,13 +45,13 @@ pkgbase = hydrus
optdepends = swftools: to display SWF thumbnails
conflicts = hydrus-docs-dummy
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=09daba5aece87bed69e19a0be5dff5ca2e66127e
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=6ace03f784984d55cc7c2eb89e5b0b50b8b220fc
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 60411b8253db6a6f996d13701330ed76da44af4ce286d7c19276d85dbc7317fa
+ sha256sums = f9f5a5927c7f2c016dbab3e4135a921918617ba393babd9b6a903ff5d0154cdd
sha256sums = 39d3404b75320be6a9e33dc256f4fc313c65fe11458e96bd5af6268c2f78eaf0
sha256sums = 5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 661097d66e92..f326212a44df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ options=(!strip) # Don't strip libs because there aren't any
pkgname=hydrus
_pkgname=hydrus
-pkgver=561
+pkgver=562
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -37,13 +37,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
# 'speedcopy: may speed up file transfers'
'swftools: to display SWF thumbnails')
conflicts=(hydrus-docs-dummy)
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=09daba5aece87bed69e19a0be5dff5ca2e66127e"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=6ace03f784984d55cc7c2eb89e5b0b50b8b220fc"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '60411b8253db6a6f996d13701330ed76da44af4ce286d7c19276d85dbc7317fa'
+ 'f9f5a5927c7f2c016dbab3e4135a921918617ba393babd9b6a903ff5d0154cdd'
'39d3404b75320be6a9e33dc256f4fc313c65fe11458e96bd5af6268c2f78eaf0'
'5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 8a0b5244f38e..72d6fe795fca 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,16 +1,3 @@
-diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index 62a61e1f..34b2506a 100644
---- a/hydrus/client/gui/ClientGUI.py
-+++ b/hydrus/client/gui/ClientGUI.py
-@@ -6213,7 +6213,7 @@ class FrameGUI( CAC.ApplicationCommandProcessorMixin, ClientGUITopLevelWindows.M
- python_executable = python_executable.replace( 'pythonw', 'python' )
-
-
-- server_script_path = os.path.join( HC.BASE_DIR, 'hydrus_server.py' )
-+ server_script_path = '/opt/hydrus/hydrus_server.py'
-
- cmd = [ python_executable, server_script_path, db_param ]
-
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
index d59bf1aa..8cbf8fee 100644
--- a/hydrus/core/HydrusConstants.py