summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2015-06-22 05:05:17 +0100
committerScore_Under2015-06-22 05:05:17 +0100
commit1456b2c513291693cf9b72b62da5fbd0f32cb23a (patch)
tree0b3e100c07149e1387ac7804860038698dcaeae3
parent91fc191e031be486eff9f7a0a0466ee4ecd13ca0 (diff)
downloadaur-1456b2c513291693cf9b72b62da5fbd0f32cb23a.tar.gz
Update for v161
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--cython-workarounds.patch35
-rw-r--r--paths-in-opt.patch16
-rw-r--r--running-the-server.patch14
5 files changed, 45 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4b392f10ddf..a8710362990d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 160
+ pkgver = 161
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -25,7 +25,7 @@ pkgbase = hydrus
optdepends = ffmpeg: show duration and other information on video thumbnails
optdepends = miniupnpc: automatic port forwarding
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=54238debc3004889ae5b5777076838bece5a0d57
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=bb64ceb77b0f97edf7c415f8aded12088c539d3e
source = paths-in-opt.patch
source = running-the-server.patch
source = cython-workarounds.patch
@@ -33,9 +33,9 @@ pkgbase = hydrus
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 039fc987703dd6ea37cbef0831112d03ebf3d1e55fa38271f4d13b6fa686c5b0
- sha256sums = 9218f8b48ecf91075132914693dbc3afbd8bf0bcd69989be1c044eacb9191da3
- sha256sums = 5ee65187005e2807c98e385da122ff63c9ac856c35b4875989aad29d0f314d25
+ sha256sums = 11b50515f06e9e74cf689353cbc39e82ff3d0f4321c416cc19a95fdfb8bf2fe6
+ sha256sums = b4cd358402ac8f225fe77a60aeb89dde88ba8ad050c5b04f11c1ffd44242e9d8
+ sha256sums = 21164d22827456ecf70fca090c94af38d4bff6e128c60709437e24f031a8ae64
sha256sums = b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678
sha256sums = ac7254e3cdb359ebae302655b72b9f74b85d9e817c326fa28173791b3fb4f114
sha256sums = 9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2
diff --git a/PKGBUILD b/PKGBUILD
index e6a39cd0ce62..7fa4de2a2b50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ $build_cython || options=(!strip) # Don't strip libs because there aren't any;
DOC_DIRS=(opt/hydrus/help)
pkgname=hydrus
-pkgver=160
+pkgver=161
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -26,7 +26,7 @@ makedepends=(git)
$build_cython && makedepends+=(cython2 parallel)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding')
-source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=54238debc3004889ae5b5777076838bece5a0d57"
+source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=bb64ceb77b0f97edf7c415f8aded12088c539d3e"
paths-in-opt.patch
running-the-server.patch
cython-workarounds.patch
@@ -34,9 +34,9 @@ source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '7dd551b634da283c0acbd1a2e556b4dbce45e2eeb0127b516b18d549109239ff'
- '9218f8b48ecf91075132914693dbc3afbd8bf0bcd69989be1c044eacb9191da3'
- '5ee65187005e2807c98e385da122ff63c9ac856c35b4875989aad29d0f314d25'
+ '11b50515f06e9e74cf689353cbc39e82ff3d0f4321c416cc19a95fdfb8bf2fe6'
+ 'b4cd358402ac8f225fe77a60aeb89dde88ba8ad050c5b04f11c1ffd44242e9d8'
+ '21164d22827456ecf70fca090c94af38d4bff6e128c60709437e24f031a8ae64'
'b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678'
'ac7254e3cdb359ebae302655b72b9f74b85d9e817c326fa28173791b3fb4f114'
'9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2')
diff --git a/cython-workarounds.patch b/cython-workarounds.patch
index 5d604946c795..de91e70bb6ff 100644
--- a/cython-workarounds.patch
+++ b/cython-workarounds.patch
@@ -1,21 +1,28 @@
diff --git a/include/ClientDB.py b/include/ClientDB.py
-index 216de51..b0c2b88 100755
+index 37cfbeb..6256694 100755
--- a/include/ClientDB.py
+++ b/include/ClientDB.py
-@@ -2279,7 +2279,7 @@ class DB( HydrusDB.HydrusDB ):
- if tag_service_key == CC.COMBINED_TAG_SERVICE_KEY: service_phrase = ''
- else: service_phrase = 'service_id = ' + HydrusData.ToString( tag_service_id ) + ' AND '
+@@ -2472,7 +2472,7 @@ class DB( HydrusDB.HydrusDB ):
+ counts_iterable = self._c.execute( nonzero_counts_query )
+
-- query_hash_ids = { id for ( id, count ) in self._c.execute( 'SELECT hash_id, COUNT( DISTINCT tag_id ) FROM mappings WHERE ' + service_phrase + 'hash_id IN ' + HydrusData.SplayListForDB( query_hash_ids ) + ' AND status IN ' + HydrusData.SplayListForDB( statuses ) + ' GROUP BY hash_id;' ) if False not in ( pred( count ) for pred in tag_predicates ) }
-+ query_hash_ids = { id for ( id, count ) in self._c.execute( 'SELECT hash_id, COUNT( DISTINCT tag_id ) FROM mappings WHERE ' + service_phrase + 'hash_id IN ' + HydrusData.SplayListForDB( query_hash_ids ) + ' AND status IN ' + HydrusData.SplayListForDB( statuses ) + ' GROUP BY hash_id;' ) if False not in (lambda count:( pred( count ) for pred in tag_predicates ))(count) }
+- query_hash_ids = { id for ( id, count ) in counts_iterable if False not in ( pred( count ) for pred in tag_predicates ) }
++ query_hash_ids = { id for ( id, count ) in counts_iterable if False not in (lambda count:( pred( count ) for pred in tag_predicates ))(count) }
#
+@@ -6007,4 +6007,4 @@ class DB( HydrusDB.HydrusDB ):
+ shutil.copytree( path + os.path.sep + 'client_thumbnails', HC.CLIENT_THUMBNAILS_DIR )
+ shutil.copytree( path + os.path.sep + 'client_updates', HC.CLIENT_UPDATES_DIR )
+
+-
+\ No newline at end of file
++
diff --git a/include/ClientGUICanvas.py b/include/ClientGUICanvas.py
-index 732f8e0..e801153 100755
+index d1ae796..c9fd2f5 100755
--- a/include/ClientGUICanvas.py
+++ b/include/ClientGUICanvas.py
-@@ -50,7 +50,8 @@ NON_LARGABLY_ZOOMABLE_MIMES = [ mime for mime in HC.VIDEO if mime != HC.VIDEO_WE
+@@ -48,7 +48,8 @@ NON_ZOOMABLE_MIMES = list( HC.AUDIO ) + [ HC.APPLICATION_PDF ]
EMBED_BUTTON_MIMES = [ HC.VIDEO_FLV, HC.APPLICATION_FLASH ]
@@ -26,10 +33,10 @@ index 732f8e0..e801153 100755
( media_width, media_height ) = media.GetResolution()
diff --git a/include/ClientGUIDialogs.py b/include/ClientGUIDialogs.py
-index 3f5efb5..779be78 100755
+index 6dcd165..63fee56 100755
--- a/include/ClientGUIDialogs.py
+++ b/include/ClientGUIDialogs.py
-@@ -244,7 +244,8 @@ class Dialog( wx.Dialog ):
+@@ -243,7 +243,8 @@ class Dialog( wx.Dialog ):
def EventDialogButton( self, event ): self.EndModal( event.GetId() )
@@ -2137,10 +2144,10 @@ index c205af2..0000000
-
-HydrusSerialisable.SERIALISABLE_TYPES_TO_OBJECT_TYPES[ HydrusSerialisable.SERIALISABLE_TYPE_SEED_QUEUE ] = SeedQueue
diff --git a/include/HydrusData.py b/include/HydrusData.py
-index 4ab9f67..259f478 100644
+index 731c256..ff5e0af 100644
--- a/include/HydrusData.py
+++ b/include/HydrusData.py
-@@ -963,15 +963,15 @@ class ClientToServerContentUpdatePackage( HydrusYAMLBase ):
+@@ -981,15 +981,15 @@ class ClientToServerContentUpdatePackage( HydrusYAMLBase ):
if data_type in ( HC.CONTENT_DATA_TYPE_TAG_SIBLINGS, HC.CONTENT_DATA_TYPE_TAG_PARENTS ) and action in ( HC.CONTENT_UPDATE_PENDING, HC.CONTENT_UPDATE_PETITION ):
@@ -2458,10 +2465,10 @@ index 1b29013..2ce6c3b 100755
-
\ No newline at end of file
diff --git a/include/HydrusSerialisable.py b/include/HydrusSerialisable.py
-index 473cfe9..533f55c 100644
+index ff6805f..0e213c7 100644
--- a/include/HydrusSerialisable.py
+++ b/include/HydrusSerialisable.py
-@@ -130,4 +130,4 @@ class SerialisableBaseNamed( SerialisableBase ):
+@@ -131,4 +131,4 @@ class SerialisableBaseNamed( SerialisableBase ):
def GetName( self ): return self._name
def SetName( self, name ): self._name = name
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index a93f16e9e670..5bc2b79e3758 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index 96fef72..17061b7 100755
+index 5e2b52d..08b3e1e 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -131,7 +131,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
+@@ -132,7 +132,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
aboutinfo.SetVersion( HydrusData.ToString( HC.SOFTWARE_VERSION ) )
aboutinfo.SetDescription( CC.CLIENT_DESCRIPTION )
@@ -11,7 +11,7 @@ index 96fef72..17061b7 100755
aboutinfo.SetLicense( license )
-@@ -1884,7 +1884,7 @@ The password is cleartext here but obscured in the entry dialog. Enter a blank p
+@@ -1872,7 +1872,7 @@ The password is cleartext here but obscured in the entry dialog. Enter a blank p
elif command == '8chan_board': webbrowser.open( 'http://8ch.net/hydrus/index.html' )
elif command == 'file_integrity': self._CheckFileIntegrity()
@@ -21,10 +21,10 @@ index 96fef72..17061b7 100755
elif command == 'help_shortcuts': wx.MessageBox( CC.SHORTCUT_HELP )
elif command == 'import_files': self._ImportFiles()
diff --git a/include/ClientGUIDialogs.py b/include/ClientGUIDialogs.py
-index 3b964a7..c296c06 100755
+index a53dac3..6dcd165 100755
--- a/include/ClientGUIDialogs.py
+++ b/include/ClientGUIDialogs.py
-@@ -664,7 +664,7 @@ class DialogFirstStart( Dialog ):
+@@ -621,7 +621,7 @@ class DialogFirstStart( Dialog ):
self._ok.SetForegroundColour( ( 0, 128, 0 ) )
message1 = 'Hi, this looks like the first time you have started the hydrus client. Don\'t forget to check out the'
@@ -34,7 +34,7 @@ index 3b964a7..c296c06 100755
message3 = 'When you close this dialog, the client will start its local http server. You will probably get a firewall warning.'
message4 = 'You can block it if you like, or you can allow it. It doesn\'t phone home, or expose your files to your network; it just provides another way to locally export your files.'
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index 79580fd..0dc9d4f 100755
+index b219383..3b2e86c 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
@@ -3,9 +3,9 @@ import sys
@@ -67,10 +67,10 @@ index 79580fd..0dc9d4f 100755
PLATFORM_WINDOWS = False
diff --git a/include/HydrusServerResources.py b/include/HydrusServerResources.py
-index 8c3779c..3037df8 100644
+index 2462cff..9afda32 100644
--- a/include/HydrusServerResources.py
+++ b/include/HydrusServerResources.py
-@@ -784,11 +784,11 @@ class HydrusResourceCommandBooruThumbnail( HydrusResourceCommandBooru ):
+@@ -775,11 +775,11 @@ class HydrusResourceCommandBooruThumbnail( HydrusResourceCommandBooru ):
mime = media_result.GetMime()
if mime in HC.MIMES_WITH_THUMBNAILS: path = ClientFiles.GetThumbnailPath( hash, full_size = False )
diff --git a/running-the-server.patch b/running-the-server.patch
index 28dfd8b41f13..b7a7f00052e3 100644
--- a/running-the-server.patch
+++ b/running-the-server.patch
@@ -1,24 +1,22 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index ea9f71f..3edbf21 100755
+index 08b3e1e..7bdf441 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -234,20 +234,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
+@@ -237,18 +237,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
- HydrusData.ShowText( u'Starting server\u2026' )
+ my_scriptname = sys.argv[0]
-- my_scriptname = sys.argv[0]
--
- if my_scriptname.endswith( 'pyw' ):
-
- if HC.PLATFORM_WINDOWS or HC.PLATFORM_OSX: python_bin = 'pythonw'
- else: python_bin = 'python'
-
-- subprocess.Popen( python_bin + ' "' + HC.BASE_DIR + os.path.sep + 'server.pyw"', shell = True )
+- subprocess.Popen( [ python_bin, HC.BASE_DIR + os.path.sep + 'server.pyw' ] )
-
- else:
-
-- if HC.PLATFORM_WINDOWS: subprocess.Popen( '"' + HC.BASE_DIR + os.path.sep + 'server.exe"', shell = True )
-- else: subprocess.Popen( '"./' + HC.BASE_DIR + os.path.sep + 'server"', shell = True )
+- if HC.PLATFORM_WINDOWS: subprocess.Popen( [ HC.BASE_DIR + os.path.sep + 'server.exe' ] )
+- else: subprocess.Popen( [ './' + HC.BASE_DIR + os.path.sep + 'server' ] )
-
+ subprocess.Popen( ["hydrus-server"] )