summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2023-11-09 18:39:58 +0000
committerScore_Under2023-11-09 18:39:58 +0000
commit290a370ff479e5d50230d1b1efaf90fbc0f210eb (patch)
tree5a28c58d4abb5dfa0f35607dab0221e76a3994b4
parent2c078dd1ca4df5430eab0a9f4a079e7f2110a2f7 (diff)
downloadaur-290a370ff479e5d50230d1b1efaf90fbc0f210eb.tar.gz
Update for v551a and return to PySide6
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--hydrus-client2
3 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ce5a44929de..fd47e3c33eca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 550
+ pkgver = 551.a
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
arch = any
@@ -28,7 +28,7 @@ pkgbase = hydrus
depends = python-service-identity
depends = qt6-multimedia
depends = qt6-svg
- depends = python-pyqt6
+ depends = pyside6
optdepends = ffmpeg: show duration and other information on video thumbnails
optdepends = miniupnpc: automatic port forwarding
optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
@@ -39,21 +39,20 @@ pkgbase = hydrus
optdepends = python-dateutil: improved fuzzy date search
optdepends = python-psd-tools: handle PSD files and extract thumbnails
optdepends = python-pympler: debug menus to profile memory usage
- optdepends = python-pyqt6-charts: display bandwidth usage charts
optdepends = python-cryptography: to generate certificates for accessing client API and server via HTTPS
optdepends = python-pyopenssl: to generate certificates for accessing client API and server via HTTPS
optdepends = qt6-webengine: to display PDF thumbnails
optdepends = swftools: to display SWF thumbnails
conflicts = hydrus-docs-dummy
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=1f9b4ba8921d9694f1b5d2907dcf338cbd8c42cc
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=118680fb9590b08b84f7709e488651f94398ba38
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
sha256sums = c332728ca119b1ed4e9a4f40de79087fa90f8754535718b506954d375541f9f0
- sha256sums = b1854ecac184385f0aa48fcefd426223fac3eeec0f1180ba58b6a58b03257d68
+ sha256sums = 39d3404b75320be6a9e33dc256f4fc313c65fe11458e96bd5af6268c2f78eaf0
sha256sums = 5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 4bb51cd4bfb9..45c28f6e0fdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ options=(!strip) # Don't strip libs because there aren't any
pkgname=hydrus
_pkgname=hydrus
-pkgver=550
+pkgver=551.a
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -17,7 +17,7 @@ depends=(python python-opencv python-beautifulsoup4 python-yaml
python-service-identity # required by twisted for https hostname verification
qt6-multimedia # https://aur.archlinux.org/packages/hydrus#comment-914337
qt6-svg # https://aur.archlinux.org/packages/hydrus#comment-923550
- python-pyqt6)
+ pyside6)
makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
@@ -29,7 +29,7 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'python-dateutil: improved fuzzy date search'
'python-psd-tools: handle PSD files and extract thumbnails'
'python-pympler: debug menus to profile memory usage'
- 'python-pyqt6-charts: display bandwidth usage charts'
+ # 'python-pyqt6-charts: display bandwidth usage charts'
'python-cryptography: to generate certificates for accessing client API and server via HTTPS'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS'
'qt6-webengine: to display PDF thumbnails'
@@ -37,14 +37,14 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
# 'speedcopy: may speed up file transfers'
'swftools: to display SWF thumbnails')
conflicts=(hydrus-docs-dummy)
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=1f9b4ba8921d9694f1b5d2907dcf338cbd8c42cc"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=118680fb9590b08b84f7709e488651f94398ba38"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
'c332728ca119b1ed4e9a4f40de79087fa90f8754535718b506954d375541f9f0'
- 'b1854ecac184385f0aa48fcefd426223fac3eeec0f1180ba58b6a58b03257d68'
+ '39d3404b75320be6a9e33dc256f4fc313c65fe11458e96bd5af6268c2f78eaf0'
'5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/hydrus-client b/hydrus-client
index 060d2ef97178..e3ee4e9ab70f 100644
--- a/hydrus-client
+++ b/hydrus-client
@@ -1,4 +1,2 @@
#!/bin/sh
-: "${QT_API:=pyqt6}"
-export QT_API
exec python -OO /opt/hydrus/hydrus_client.py "$@"