summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2015-07-09 02:08:04 +0100
committerScore_Under2015-07-09 02:08:04 +0100
commit2d7890e092d4a764adc04e42c1dbfe5147c9afc1 (patch)
treeafe90d4adb041fca1d572a634e54d2e664a0f7cf
parentb682e4ea3ca89e3c722709becfbb0c23dac17f03 (diff)
downloadaur-2d7890e092d4a764adc04e42c1dbfe5147c9afc1.tar.gz
Update for v164
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--cython-workarounds.patch14
-rw-r--r--paths-in-opt.patch8
4 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9da8799c32a..ec8e93c0cf96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 163.a
+ pkgver = 164
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -25,7 +25,7 @@ pkgbase = hydrus
optdepends = ffmpeg: show duration and other information on video thumbnails
optdepends = miniupnpc: automatic port forwarding
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=1e162828f4b8c6d6790b7ab9b0fb2438ddbd3a29
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=c985f70a4ff49d0da8c5d73dc91d57356f9380db
source = paths-in-opt.patch
source = running-the-server.patch
source = cython-workarounds.patch
@@ -33,9 +33,9 @@ pkgbase = hydrus
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = f0ce34feda340f307ec4ec149547a69d0bdecafc61f6efe322c42ef0f98a3a29
+ sha256sums = faf1bcdab469bd7bfe6616897fd355642da55c3e2b269a20d477a23d5583f75b
sha256sums = b4cd358402ac8f225fe77a60aeb89dde88ba8ad050c5b04f11c1ffd44242e9d8
- sha256sums = d75842ea2f622e98cfe56d6d8785b2285399fa59bbde330b876c8c61a91cc4f6
+ sha256sums = fa39e8dda692e1f098170e4869b23c78cb8adcd1bc3c2c2b82616faa985a0412
sha256sums = b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678
sha256sums = ac7254e3cdb359ebae302655b72b9f74b85d9e817c326fa28173791b3fb4f114
sha256sums = 9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2
diff --git a/PKGBUILD b/PKGBUILD
index 26adde31c196..5b6bb790120a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ $build_cython || options=(!strip) # Don't strip libs because there aren't any;
DOC_DIRS=(opt/hydrus/help)
pkgname=hydrus
-pkgver=163.a
+pkgver=164
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -26,7 +26,7 @@ makedepends=(git)
$build_cython && makedepends+=(cython2 parallel)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding')
-source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=1e162828f4b8c6d6790b7ab9b0fb2438ddbd3a29"
+source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=c985f70a4ff49d0da8c5d73dc91d57356f9380db"
paths-in-opt.patch
running-the-server.patch
cython-workarounds.patch
@@ -34,9 +34,9 @@ source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- 'f0ce34feda340f307ec4ec149547a69d0bdecafc61f6efe322c42ef0f98a3a29'
+ 'faf1bcdab469bd7bfe6616897fd355642da55c3e2b269a20d477a23d5583f75b'
'b4cd358402ac8f225fe77a60aeb89dde88ba8ad050c5b04f11c1ffd44242e9d8'
- 'd75842ea2f622e98cfe56d6d8785b2285399fa59bbde330b876c8c61a91cc4f6'
+ 'fa39e8dda692e1f098170e4869b23c78cb8adcd1bc3c2c2b82616faa985a0412'
'b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678'
'ac7254e3cdb359ebae302655b72b9f74b85d9e817c326fa28173791b3fb4f114'
'9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2')
diff --git a/cython-workarounds.patch b/cython-workarounds.patch
index 7c0cd10d5891..6665bec42cd3 100644
--- a/cython-workarounds.patch
+++ b/cython-workarounds.patch
@@ -1,8 +1,8 @@
diff --git a/include/ClientDB.py b/include/ClientDB.py
-index 5b1b712..2fa1732 100755
+index 0d1b6f8..51e06e4 100755
--- a/include/ClientDB.py
+++ b/include/ClientDB.py
-@@ -2491,7 +2491,7 @@ class DB( HydrusDB.HydrusDB ):
+@@ -2563,7 +2563,7 @@ class DB( HydrusDB.HydrusDB ):
counts_iterable = self._c.execute( nonzero_counts_query )
@@ -11,7 +11,7 @@ index 5b1b712..2fa1732 100755
#
-@@ -6100,4 +6100,4 @@ class DB( HydrusDB.HydrusDB ):
+@@ -6248,4 +6248,4 @@ class DB( HydrusDB.HydrusDB ):
shutil.copytree( path + os.path.sep + 'client_thumbnails', HC.CLIENT_THUMBNAILS_DIR )
shutil.copytree( path + os.path.sep + 'client_updates', HC.CLIENT_UPDATES_DIR )
@@ -19,7 +19,7 @@ index 5b1b712..2fa1732 100755
\ No newline at end of file
+
diff --git a/include/ClientGUICanvas.py b/include/ClientGUICanvas.py
-index 5882175..9d623ac 100755
+index 2fe9e3d..74e388c 100755
--- a/include/ClientGUICanvas.py
+++ b/include/ClientGUICanvas.py
@@ -48,7 +48,8 @@ NON_ZOOMABLE_MIMES = list( HC.AUDIO ) + [ HC.APPLICATION_PDF ]
@@ -33,7 +33,7 @@ index 5882175..9d623ac 100755
( media_width, media_height ) = media.GetResolution()
diff --git a/include/ClientGUIDialogs.py b/include/ClientGUIDialogs.py
-index 19ed8e3..398fc7d 100755
+index 520e94c..09f3971 100755
--- a/include/ClientGUIDialogs.py
+++ b/include/ClientGUIDialogs.py
@@ -243,7 +243,8 @@ class Dialog( wx.Dialog ):
@@ -47,7 +47,7 @@ index 19ed8e3..398fc7d 100755
wx.Dialog.SetInitialSize( self, ( width, height ) )
diff --git a/include/ClientGUIManagement.py b/include/ClientGUIManagement.py
-index 71b5491..0b4cf7c 100755
+index abfd02f..22e7a15 100755
--- a/include/ClientGUIManagement.py
+++ b/include/ClientGUIManagement.py
@@ -63,26 +63,6 @@ def CreateManagementController( management_type, file_service_key = None ):
@@ -1377,7 +1377,7 @@ index 98576c6..0000000
-
-HydrusSerialisable.SERIALISABLE_TYPES_TO_OBJECT_TYPES[ HydrusSerialisable.SERIALISABLE_TYPE_SEED_QUEUE ] = SeedQueue
diff --git a/include/HydrusData.py b/include/HydrusData.py
-index 60345e8..2a9d747 100644
+index aa4a331..695e1e2 100644
--- a/include/HydrusData.py
+++ b/include/HydrusData.py
@@ -999,15 +999,15 @@ class ClientToServerContentUpdatePackage( HydrusYAMLBase ):
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index d43bf73c166e..30dbb71fae8f 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,5 +1,5 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index 2b1ba90..791f3e3 100755
+index cb87bf1..201c069 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
@@ -132,7 +132,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
@@ -11,7 +11,7 @@ index 2b1ba90..791f3e3 100755
aboutinfo.SetLicense( license )
-@@ -1907,7 +1907,7 @@ The password is cleartext here but obscured in the entry dialog. Enter a blank p
+@@ -1908,7 +1908,7 @@ The password is cleartext here but obscured in the entry dialog. Enter a blank p
elif command == '8chan_board': webbrowser.open( 'http://8ch.net/hydrus/index.html' )
elif command == 'file_integrity': self._CheckFileIntegrity()
@@ -21,7 +21,7 @@ index 2b1ba90..791f3e3 100755
elif command == 'help_shortcuts': wx.MessageBox( CC.SHORTCUT_HELP )
elif command == 'import_files': self._ImportFiles()
diff --git a/include/ClientGUIDialogs.py b/include/ClientGUIDialogs.py
-index 29aeb23..19ed8e3 100755
+index 7ffd518..520e94c 100755
--- a/include/ClientGUIDialogs.py
+++ b/include/ClientGUIDialogs.py
@@ -621,7 +621,7 @@ class DialogFirstStart( Dialog ):
@@ -34,7 +34,7 @@ index 29aeb23..19ed8e3 100755
message3 = 'When you close this dialog, the client will start its local http server. You will probably get a firewall warning.'
message4 = 'You can block it if you like, or you can allow it. It doesn\'t phone home, or expose your files to your network; it just provides another way to locally export your files.'
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index a4100c1..a070e15 100755
+index ef81009..18d7831 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
@@ -3,9 +3,9 @@ import sys