summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2016-10-13 00:30:57 +0100
committerScore_Under2016-10-13 00:30:57 +0100
commit3274a27c8a7855cc4021ebdfd4ee365ae94d8b7f (patch)
tree94f71734042e062ec94167058a8c2739134cf459
parent8c50678a64469bf76373f347b7cfe9dff65169e7 (diff)
downloadaur-3274a27c8a7855cc4021ebdfd4ee365ae94d8b7f.tar.gz
Update for v227
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch25
3 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 591ce989d29e..b204daa949cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Oct 6 02:36:28 UTC 2016
+# Wed Oct 12 23:27:09 UTC 2016
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 226
+ pkgver = 227
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
arch = any
@@ -32,13 +32,13 @@ pkgbase = hydrus
optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
options = !strip
options = docs
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=d9c19530e6939917c78bbee751811b1a23857d23
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=64bd5a232b5178a67ac7ba32dd43a55c9221be1e
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = aa7da3e5215cf103cd07460747035661d03b10ec2312db9cbdf66ca83f1e0922
+ sha256sums = d3013e87a70c21ad7c9f919f4a1816977639671e5b9bbd7de2590454e0dc100a
sha256sums = b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678
sha256sums = 5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b
sha256sums = 9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2
diff --git a/PKGBUILD b/PKGBUILD
index ce6c0444fc46..b335ece7da46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus hydrus-docs hydrus-sources)
-pkgver=226
+pkgver=227
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -18,13 +18,13 @@ makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus')
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=d9c19530e6939917c78bbee751811b1a23857d23"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=64bd5a232b5178a67ac7ba32dd43a55c9221be1e"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- 'aa7da3e5215cf103cd07460747035661d03b10ec2312db9cbdf66ca83f1e0922'
+ 'd3013e87a70c21ad7c9f919f4a1816977639671e5b9bbd7de2590454e0dc100a'
'b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678'
'5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b'
'9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index c2ec1f98331c..ffc6a1c92a2b 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,5 +1,5 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index 830b3aa..8f50075 100755
+index 8451548..d11ebd2 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
@@ -174,7 +174,7 @@ class FrameGUI( ClientGUITopLevelWindows.FrameThatResizes ):
@@ -21,10 +21,10 @@ index 830b3aa..8f50075 100755
time_waited = 0
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index 2cf7e68..1c3ce60 100755
+index f7eed65..7d110bb 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
-@@ -3,33 +3,21 @@ import sys
+@@ -3,27 +3,12 @@ import sys
# dirs
@@ -46,24 +46,15 @@ index 2cf7e68..1c3ce60 100755
-
-
-BIN_DIR = os.path.join( BASE_DIR, 'bin' )
+-HELP_DIR = os.path.join( BASE_DIR, 'help' )
+-INCLUDE_DIR = os.path.join( BASE_DIR, 'include' )
+-STATIC_DIR = os.path.join( BASE_DIR, 'static' )
+BASE_DIR = os.path.expanduser("~/.local/share/hydrus")
+
+BIN_DIR = "/opt/hydrus/bin"
- DB_DIR = os.path.join( BASE_DIR, 'db' )
- SERVER_FILES_DIR = os.path.join( DB_DIR, 'server_files' )
- CLIENT_UPDATES_DIR = os.path.join( DB_DIR, 'client_updates' )
- SERVER_UPDATES_DIR = os.path.join( DB_DIR, 'server_updates' )
--HELP_DIR = os.path.join( BASE_DIR, 'help' )
+HELP_DIR = "/opt/hydrus/help"
- INCLUDE_DIR = os.path.join( BASE_DIR, 'include' )
--STATIC_DIR = os.path.join( BASE_DIR, 'static' )
++INCLUDE_DIR = "/opt/hydrus/include"
+STATIC_DIR = "/opt/hydrus/static"
--#
-+try:
-+ os.makedirs(DB_DIR)
-+except os.error:
-+ pass
+ #
- PLATFORM_WINDOWS = False
- PLATFORM_OSX = False