summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2015-09-03 01:23:46 +0100
committerScore_Under2015-09-03 01:23:46 +0100
commit42006928a89ba3b6d88b013cf1c531bb13796d7e (patch)
tree33969023e9ea70666ed2f513bbc8f171ce63eb55
parentf78ce01eb71c2b3c966b811fae54f4b681018d98 (diff)
downloadaur-42006928a89ba3b6d88b013cf1c531bb13796d7e.tar.gz
Update for v172
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--hydrus-server2
-rw-r--r--paths-in-opt.patch6
-rw-r--r--running-the-server.patch27
5 files changed, 33 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13a8aa1ba647..911b987d8c18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 171
+ pkgver = 172
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -28,17 +28,17 @@ pkgbase = hydrus
optdepends = miniupnpc: automatic port forwarding
optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=a61df3303cf69a613fbfe43bf4ba78d172a1c676
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=91b77e664811f2f4e5a8325db240445ffa1a8226
source = paths-in-opt.patch
source = running-the-server.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 9575e8a46d04ad8a2f6d53612bf4c4e2905fe1f2d80a10aaeff5ef4cfbb249ce
- sha256sums = 1c2c154d044f56fb50a1f24b940f6127ef78640a723422af5e5853838deee03b
+ sha256sums = 7bba0d627ef885c589da9cbdef2ebd98a6e69ce95a863dc2edcfae826880b1f4
+ sha256sums = f7ba3a9232ebf7b73d9a4713761a09a14c2e4fe61eb37239c1b650bcc4a2ed75
sha256sums = b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678
- sha256sums = ac7254e3cdb359ebae302655b72b9f74b85d9e817c326fa28173791b3fb4f114
+ sha256sums = 5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b
sha256sums = 9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2
pkgname = hydrus
diff --git a/PKGBUILD b/PKGBUILD
index f0d0fe237a32..d75b6930cfc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ options=(!strip) # Don't strip libs because there aren't any; this wastes time
DOC_DIRS=(opt/hydrus/help)
pkgname=hydrus
-pkgver=171
+pkgver=172
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -26,17 +26,17 @@ makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus')
-source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=a61df3303cf69a613fbfe43bf4ba78d172a1c676"
+source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=91b77e664811f2f4e5a8325db240445ffa1a8226"
paths-in-opt.patch
running-the-server.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '9575e8a46d04ad8a2f6d53612bf4c4e2905fe1f2d80a10aaeff5ef4cfbb249ce'
- '1c2c154d044f56fb50a1f24b940f6127ef78640a723422af5e5853838deee03b'
+ '7bba0d627ef885c589da9cbdef2ebd98a6e69ce95a863dc2edcfae826880b1f4'
+ 'f7ba3a9232ebf7b73d9a4713761a09a14c2e4fe61eb37239c1b650bcc4a2ed75'
'b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678'
- 'ac7254e3cdb359ebae302655b72b9f74b85d9e817c326fa28173791b3fb4f114'
+ '5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b'
'9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2')
install=hydrus.install
@@ -69,7 +69,7 @@ package() {
# Create /opt/hydrus and copy hydrus sources to there
install -m755 -d "${pkgdir}/opt/hydrus"
- cp -r help include static client.pyw server.pyw "${pkgdir}/opt/hydrus/"
+ cp -r help include static client.pyw server.py "${pkgdir}/opt/hydrus/"
# Remove .py files
$remove_py && find "${pkgdir}/opt/hydrus" -name '*.py' -delete
diff --git a/hydrus-server b/hydrus-server
index 66f4bbc158f3..d63352936aa9 100644
--- a/hydrus-server
+++ b/hydrus-server
@@ -1,2 +1,2 @@
#!/bin/sh
-exec python2 -OO /opt/hydrus/server.pyw "$@"
+exec python2 -OO /opt/hydrus/server.py "$@"
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 31aa58ca949b..840c271562fc 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,5 +1,5 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index df287e2..af0afba 100755
+index 1d4024f..d7e1afd 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
@@ -136,7 +136,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
@@ -11,7 +11,7 @@ index df287e2..af0afba 100755
aboutinfo.SetLicense( license )
-@@ -1987,7 +1987,7 @@ The password is cleartext here but obscured in the entry dialog. Enter a blank p
+@@ -2014,7 +2014,7 @@ The password is cleartext here but obscured in the entry dialog. Enter a blank p
elif command == '8chan_board': webbrowser.open( 'http://8ch.net/hydrus/index.html' )
elif command == 'file_integrity': self._CheckFileIntegrity()
@@ -62,7 +62,7 @@ index 4d8c363..b5119b6 100644
\ No newline at end of file
+
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index e3fea73..5c87f83 100755
+index 0a834c4..fa0aa39 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
@@ -3,9 +3,9 @@ import sys
diff --git a/running-the-server.patch b/running-the-server.patch
index 4b64185c8fed..d3cf804e42d4 100644
--- a/running-the-server.patch
+++ b/running-the-server.patch
@@ -1,22 +1,31 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index af0afba..c885196 100755
+index a4be697..1319e86 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -244,18 +244,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
+@@ -242,27 +242,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
- my_scriptname = sys.argv[0]
+ HydrusData.ShowText( u'Starting server\u2026' )
-- if my_scriptname.endswith( 'pyw' ):
+- if HC.PLATFORM_WINDOWS:
-
-- if HC.PLATFORM_WINDOWS or HC.PLATFORM_OSX: python_bin = 'pythonw'
-- else: python_bin = 'python'
--
-- subprocess.Popen( [ python_bin, HC.BASE_DIR + os.path.sep + 'server.pyw' ] )
+- my_exe = HC.BASE_DIR + os.path.sep + 'client.exe'
-
- else:
-
+- my_exe = HC.BASE_DIR + os.path.sep + 'client'
+-
+-
+- if sys.executable == my_exe:
+-
- if HC.PLATFORM_WINDOWS: subprocess.Popen( [ HC.BASE_DIR + os.path.sep + 'server.exe' ] )
-- else: subprocess.Popen( [ './' + HC.BASE_DIR + os.path.sep + 'server' ] )
+- else: subprocess.Popen( [ '.' + HC.BASE_DIR + os.path.sep + 'server' ] )
+-
+- else:
+-
+- if HC.PLATFORM_WINDOWS or HC.PLATFORM_OSX: python_bin = 'pythonw'
+- else: python_bin = 'python'
+-
+- subprocess.Popen( [ python_bin, HC.BASE_DIR + os.path.sep + 'server.py' ] )
-
+ subprocess.Popen( ["hydrus-server"] )