summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Serajnik2021-03-18 00:33:40 +0100
committerMichael Serajnik2021-03-18 00:33:40 +0100
commit42f59dbe20bf74259e92457feb800e45001f70c7 (patch)
tree6e6da8c348e3f4e327daaaf180949ff4e4b3b8d6
parent6bd991c63e53869c9968985e1aa3192921bbb3b7 (diff)
downloadaur-42f59dbe20bf74259e92457feb800e45001f70c7.tar.gz
Update for v433
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch21
3 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffdec201a6b7..5374d5e2e6d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 432
+ pkgver = 433
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -34,13 +34,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=d56cb43f07254f407ad7056770526b5031a709c9
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=4cefd895b55131d2a9c1433d71dd98815e654241
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = bac23f99d7ac1fea5c1fea4c3ff478c1fc327017b6a68be1212d752390f252fd
+ sha256sums = 3cf240b1f3fc405b4e86030e45d54984bd425e37c6f48205a9419c2c0a94bcd2
sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 3d070819b4f5..075579e7dfcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=432
+pkgver=433
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -24,13 +24,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-pyqtchart: display bandwidth usage charts'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=d56cb43f07254f407ad7056770526b5031a709c9"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=4cefd895b55131d2a9c1433d71dd98815e654241"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- 'bac23f99d7ac1fea5c1fea4c3ff478c1fc327017b6a68be1212d752390f252fd'
+ '3cf240b1f3fc405b4e86030e45d54984bd425e37c6f48205a9419c2c0a94bcd2'
'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 80ad33684de4..8bb3275287e5 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index db9fd6f..c925431 100644
+index c73d9a8..717afce 100644
--- a/hydrus/client/gui/ClientGUI.py
+++ b/hydrus/client/gui/ClientGUI.py
-@@ -792,7 +792,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
+@@ -3903,7 +3903,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -12,7 +12,7 @@ index db9fd6f..c925431 100644
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
-index 857715d..ff6a7ae 100644
+index a9eef8d..ca32f46 100644
--- a/hydrus/core/HydrusConstants.py
+++ b/hydrus/core/HydrusConstants.py
@@ -5,33 +5,9 @@ import typing
@@ -52,7 +52,7 @@ index 857715d..ff6a7ae 100644
PLATFORM_WINDOWS = sys.platform == 'win32'
PLATFORM_MACOS = sys.platform == 'darwin'
-@@ -41,23 +17,16 @@ PLATFORM_HAIKU = sys.platform == 'haiku1'
+@@ -41,32 +17,16 @@ PLATFORM_HAIKU = sys.platform == 'haiku1'
RUNNING_FROM_SOURCE = sys.argv[0].endswith( '.py' ) or sys.argv[0].endswith( '.pyw' )
RUNNING_FROM_MACOS_APP = os.path.exists( os.path.join( BASE_DIR, 'running_from_app' ) )
@@ -69,11 +69,20 @@ index 857715d..ff6a7ae 100644
-if PLATFORM_MACOS:
-
-- USERPATH_DB_DIR = os.path.join( os.path.expanduser( '~' ), 'Library', 'Hydrus' )
+- desired_userpath_db_dir = os.path.join( '~', 'Library', 'Hydrus' )
-
-else:
-
-- USERPATH_DB_DIR = os.path.join( os.path.expanduser( '~' ), 'Hydrus' )
+- desired_userpath_db_dir = os.path.join( '~', 'Hydrus' )
+-
+-
+-USERPATH_DB_DIR = os.path.expanduser( desired_userpath_db_dir )
+-
+-if USERPATH_DB_DIR == desired_userpath_db_dir:
+-
+- # could not figure it out, probably a crazy user situation atm
+-
+- USERPATH_DB_DIR = None
-
+USERPATH_DB_DIR = DEFAULT_DB_DIR