summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2023-09-13 23:38:02 +0100
committerScore_Under2023-09-13 23:38:02 +0100
commit4b8d12f02b2e77056d6a5eddbd8556f1e741d75c (patch)
treeb3b624e0c6405698ada88e312013ce899285db1e
parent818d5f72d3b58c2b841fa0bad2c8d7e866117a95 (diff)
downloadaur-4b8d12f02b2e77056d6a5eddbd8556f1e741d75c.tar.gz
Update for v543
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--unimported-types.patch13
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e93802fc94be..59fb49eff38e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 542
+ pkgver = 543
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
arch = any
@@ -45,13 +45,15 @@ pkgbase = hydrus
optdepends = swftools: to display SWF thumbnails
conflicts = hydrus-docs-dummy
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=7d63c5d90c9c0ff53c0a116f0ac40d93b42b66b8
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=b840d0778c0842d64967fbc877afa60dda1faf26
source = paths-in-opt.patch
+ source = unimported-types.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
sha256sums = c332728ca119b1ed4e9a4f40de79087fa90f8754535718b506954d375541f9f0
+ sha256sums = f1118020fc49d33703c78340d478b1a20910cf911d3eb0c335aa9850d8136bab
sha256sums = b1854ecac184385f0aa48fcefd426223fac3eeec0f1180ba58b6a58b03257d68
sha256sums = 5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index b27e6eea525f..bab4b51da503 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ options=(!strip) # Don't strip libs because there aren't any
pkgname=hydrus
_pkgname=hydrus
-pkgver=542
+pkgver=543
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -36,13 +36,15 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
# 'speedcopy: may speed up file transfers'
'swftools: to display SWF thumbnails')
conflicts=(hydrus-docs-dummy)
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=7d63c5d90c9c0ff53c0a116f0ac40d93b42b66b8"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=b840d0778c0842d64967fbc877afa60dda1faf26"
paths-in-opt.patch
+ unimported-types.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
'c332728ca119b1ed4e9a4f40de79087fa90f8754535718b506954d375541f9f0'
+ 'f1118020fc49d33703c78340d478b1a20910cf911d3eb0c335aa9850d8136bab'
'b1854ecac184385f0aa48fcefd426223fac3eeec0f1180ba58b6a58b03257d68'
'5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
@@ -50,6 +52,7 @@ sha256sums=('SKIP'
prepare() {
cd "${srcdir}/${_pkgname}"
patch -Np1 < ../paths-in-opt.patch
+ patch -Np1 < ../unimported-types.patch
}
build() {
diff --git a/unimported-types.patch b/unimported-types.patch
new file mode 100644
index 000000000000..7e01a22b779b
--- /dev/null
+++ b/unimported-types.patch
@@ -0,0 +1,13 @@
+diff --git a/hydrus/core/HydrusPSDHandling.py b/hydrus/core/HydrusPSDHandling.py
+index 49c573e0..b73caf15 100644
+--- a/hydrus/core/HydrusPSDHandling.py
++++ b/hydrus/core/HydrusPSDHandling.py
+@@ -107,7 +107,7 @@ def GetPSDResolutionFallback( path: str ):
+ # modified from psd-tools source:
+ # https://github.com/psd-tools/psd-tools/blob/main/src/psd_tools/api/pil_io.py
+
+-def convert_image_data_to_pil(psd: PSDImage):
++def convert_image_data_to_pil(psd: 'PSDImage'):
+ alpha = None
+
+ channel_data = psd._record.image_data.get_data(psd._record.header)