summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2017-03-02 05:15:46 +0000
committerScore_Under2017-03-02 05:15:46 +0000
commit5f1ccc5565b66cf5d9db6abe20cdafdf159f009b (patch)
treedbb5790ed3ae2798865affffb726f2d2107ff43b
parent51980e6de526a487426f34305defad7e857a502f (diff)
downloadaur-5f1ccc5565b66cf5d9db6abe20cdafdf159f009b.tar.gz
Update for v245a
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch10
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d8619e691f5..976c1f2331bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Feb 9 08:56:08 UTC 2017
+# Thu Mar 2 04:58:19 UTC 2017
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 244.a
+ pkgver = 245.a
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -34,13 +34,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=283a073ba88fb2c2e5178305669dc61c21ee885e
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=9b9388f71cb295287cc8476e9e3c87341c74d125
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 495605cba87d031cfb864ecb593fd9d75085dc13685bfbb7a077fd6367d4198d
+ sha256sums = 27a2410aec740630195519dd27d33f0cc95085a99cc771668fe0821a7fdc621e
sha256sums = b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678
sha256sums = 5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 922b782758f4..117286cc27f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=244.a
+pkgver=245.a
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -20,13 +20,13 @@ makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus')
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=283a073ba88fb2c2e5178305669dc61c21ee885e"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=9b9388f71cb295287cc8476e9e3c87341c74d125"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '495605cba87d031cfb864ecb593fd9d75085dc13685bfbb7a077fd6367d4198d'
+ '27a2410aec740630195519dd27d33f0cc95085a99cc771668fe0821a7fdc621e'
'b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678'
'5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index c2237773cf08..8002087d61e1 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,18 +1,18 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index db5a7e7..b12df2c 100755
+index d5efb6c..340830d 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -383,7 +383,7 @@ class FrameGUI( ClientGUITopLevelWindows.FrameThatResizes ):
+@@ -394,7 +394,7 @@ class FrameGUI( ClientGUITopLevelWindows.FrameThatResizes ):
python_executable = python_executable.replace( 'pythonw', 'python' )
-- subprocess.Popen( [ python_executable, os.path.join( HC.BASE_DIR, 'server.py' ) ] )
-+ subprocess.Popen( [ python_executable, '/opt/hydrus/server.py' ] )
+- subprocess.Popen( [ python_executable, os.path.join( HC.BASE_DIR, 'server.py' ), db_dir ] )
++ subprocess.Popen( [ python_executable, '/opt/hydrus/server.py', db_dir ] )
time_waited = 0
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index 2cbc4b0..13038df 100755
+index 7565ea3..74fe741 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
@@ -3,30 +3,15 @@ import sys