summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2019-11-21 00:47:36 +0000
committerScore_Under2019-11-21 00:47:36 +0000
commit823011488eed0b1a3fdb33639ac40ac80550471b (patch)
treee93457d0aed22df536b8062e67d43e5d092901d4
parentc8fe960b273b9c3651cbe9fcfb4cd9198dbe819c (diff)
downloadaur-823011488eed0b1a3fdb33639ac40ac80550471b.tar.gz
Update for v374
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--paths-in-opt.patch12
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 152f519a2ef2..0dc197ac075d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 373
- pkgrel = 2
+ pkgver = 374
+ pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
arch = any
@@ -30,13 +30,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=69019f844f29a4e06f8d7c7097aba0b7bbeb80bf
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=4d4f39984e422e45a3e1bac29668eb330a899ae1
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 5c3be57fc5f612ff4bbe569b277caf4ec9faa75cb17dec4bc4be435bb7a7c933
+ sha256sums = 5cd4414cbf226eddc6319216a6def95e73c148f37746effaae983a4c690b71a2
sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index d88ca04b270c..14e008223333 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=373
-pkgrel=2
+pkgver=374
+pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
license=(WTFPL)
@@ -21,13 +21,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus'
)
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=69019f844f29a4e06f8d7c7097aba0b7bbeb80bf"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=4d4f39984e422e45a3e1bac29668eb330a899ae1"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '5c3be57fc5f612ff4bbe569b277caf4ec9faa75cb17dec4bc4be435bb7a7c933'
+ '5cd4414cbf226eddc6319216a6def95e73c148f37746effaae983a4c690b71a2'
'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index d0ed5692ff8c..2e6183008913 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index 1d39c4f..e506341 100755
+index 479efc1..86cbd71 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -397,7 +397,7 @@ class FrameGUI( ClientGUITopLevelWindows.FrameThatResizes ):
+@@ -598,7 +598,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -12,7 +12,7 @@ index 1d39c4f..e506341 100755
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index 7b45015..47fc32c 100755
+index 9ec3402..0ea9266 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
@@ -2,30 +2,9 @@ import os
@@ -47,10 +47,10 @@ index 7b45015..47fc32c 100755
+BASE_DIR = os.path.expanduser("~/.local/share/hydrus")
PLATFORM_WINDOWS = False
- PLATFORM_OSX = False
+ PLATFORM_MACOS = False
@@ -38,23 +17,16 @@ elif sys.platform == 'linux': PLATFORM_LINUX = True
RUNNING_FROM_SOURCE = sys.argv[0].endswith( '.py' ) or sys.argv[0].endswith( '.pyw' )
- RUNNING_FROM_OSX_APP = os.path.exists( os.path.join( BASE_DIR, 'running_from_app' ) )
+ RUNNING_FROM_MACOS_APP = os.path.exists( os.path.join( BASE_DIR, 'running_from_app' ) )
-BIN_DIR = os.path.join( BASE_DIR, 'bin' )
-HELP_DIR = os.path.join( BASE_DIR, 'help' )
@@ -63,7 +63,7 @@ index 7b45015..47fc32c 100755
DEFAULT_DB_DIR = os.path.join( BASE_DIR, 'db' )
--if PLATFORM_OSX:
+-if PLATFORM_MACOS:
-
- USERPATH_DB_DIR = os.path.join( os.path.expanduser( '~' ), 'Library', 'Hydrus' )
-