summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2022-04-14 20:40:32 +0100
committerScore_Under2022-04-14 20:40:32 +0100
commitb21e088b9fdb0adfddde903748872f602535c5f4 (patch)
treea5083c7df7d3b21e0c7224e3e8c3074970704944
parent448cf719219c40efb8bfe8c7ce8f2b0e6d2fd912 (diff)
downloadaur-b21e088b9fdb0adfddde903748872f602535c5f4.tar.gz
Update for v481
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch17
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac313c4726f1..3e72a78bf92f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 480
+ pkgver = 481
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -38,13 +38,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=92fcd8dccbd0ca1b74e59c3378ad8f76a5ee4427
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=897b0fbebb93692bf452f764fdca067b61668d4a
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 6dde03b452b842d089cfdffb4cf8554b4985934d664054b2bb71006694f923c6
+ sha256sums = 5ada0e317adf6793733fb1f9b433eb95a4e985de70d068a40a72bd19df097cbc
sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index f02c971a006b..ca37ab601e96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgname=hydrus
_pkgname=hydrus
-pkgver=480
+pkgver=481
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -24,13 +24,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-pyqt5-chart: display bandwidth usage charts'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=92fcd8dccbd0ca1b74e59c3378ad8f76a5ee4427"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=897b0fbebb93692bf452f764fdca067b61668d4a"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '6dde03b452b842d089cfdffb4cf8554b4985934d664054b2bb71006694f923c6'
+ '5ada0e317adf6793733fb1f9b433eb95a4e985de70d068a40a72bd19df097cbc'
'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 64ec3007c32a..f8fd5d00b701 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index 418c93e..91e2683 100644
+index 944af47..8e9bcce 100644
--- a/hydrus/client/gui/ClientGUI.py
+++ b/hydrus/client/gui/ClientGUI.py
-@@ -4133,7 +4133,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
+@@ -5969,7 +5969,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -12,10 +12,10 @@ index 418c93e..91e2683 100644
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
-index db6a88b..49e5fdb 100644
+index 03453fe..7a53939 100644
--- a/hydrus/core/HydrusConstants.py
+++ b/hydrus/core/HydrusConstants.py
-@@ -5,33 +5,9 @@ import typing
+@@ -7,34 +7,9 @@ import yaml
# old method of getting frozen dir, doesn't work for symlinks looks like:
# BASE_DIR = getattr( sys, '_MEIPASS', None )
@@ -46,13 +46,14 @@ index db6a88b..49e5fdb 100644
-
- BASE_DIR = os.getcwd()
-
+-
+RUNNING_FROM_FROZEN_BUILD = False
+HYDRUS_MODULE_DIR = '/opt/hydrus/hydrus'
+BASE_DIR = os.path.expanduser("~/.local/share/hydrus")
muh_platform = sys.platform.lower()
-@@ -43,32 +19,16 @@ PLATFORM_HAIKU = muh_platform == 'haiku1'
+@@ -46,32 +21,16 @@ PLATFORM_HAIKU = muh_platform == 'haiku1'
RUNNING_FROM_SOURCE = sys.argv[0].endswith( '.py' ) or sys.argv[0].endswith( '.pyw' )
RUNNING_FROM_MACOS_APP = os.path.exists( os.path.join( BASE_DIR, 'running_from_app' ) )
@@ -75,7 +76,8 @@ index db6a88b..49e5fdb 100644
-
- desired_userpath_db_dir = os.path.join( '~', 'Hydrus' )
-
--
++USERPATH_DB_DIR = DEFAULT_DB_DIR
+
-USERPATH_DB_DIR = os.path.expanduser( desired_userpath_db_dir )
-
-if USERPATH_DB_DIR == desired_userpath_db_dir:
@@ -84,8 +86,7 @@ index db6a88b..49e5fdb 100644
-
- USERPATH_DB_DIR = None
-
-+USERPATH_DB_DIR = DEFAULT_DB_DIR
-
+-
-LICENSE_PATH = os.path.join( BASE_DIR, 'license.txt' )
+LICENSE_PATH = "/usr/share/licenses/hydrus/license.txt"