summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2017-06-12 12:40:35 +0100
committerScore_Under2017-06-12 12:40:35 +0100
commitc2e4933c3dfc038ea9503b12c99ae364eb94711f (patch)
treea09301f3e8b18a50f4c3a43573fb50b9eec36c3b
parentb27fde4d6f8949ea0a6b3250cec485d801f4d094 (diff)
downloadaur-c2e4933c3dfc038ea9503b12c99ae364eb94711f.tar.gz
Update for v259
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch14
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 499f71a2796b..6faa46c79ba4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jun 1 01:34:44 UTC 2017
+# Thu Jun 8 02:22:54 UTC 2017
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 258
+ pkgver = 259
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -34,13 +34,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=490b7e4ab831d1059a6ac7fc45e9d30824cc257d
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=a73d18d6c431cf96fe2096febd6fb8d069026adf
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 27a2410aec740630195519dd27d33f0cc95085a99cc771668fe0821a7fdc621e
+ sha256sums = 520fdc156dfb8c4a8c9a0c8c05e51807266809cddeca27a5b73049b2355c3a40
sha256sums = b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678
sha256sums = 5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 06b6478ad7e0..810f552fadb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=258
+pkgver=259
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -20,13 +20,13 @@ makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus')
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=490b7e4ab831d1059a6ac7fc45e9d30824cc257d"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=a73d18d6c431cf96fe2096febd6fb8d069026adf"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '27a2410aec740630195519dd27d33f0cc95085a99cc771668fe0821a7fdc621e'
+ '520fdc156dfb8c4a8c9a0c8c05e51807266809cddeca27a5b73049b2355c3a40'
'b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678'
'5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 8002087d61e1..36c05a157242 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,18 +1,18 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index d5efb6c..340830d 100755
+index 92828e0..297bd0e 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -394,7 +394,7 @@ class FrameGUI( ClientGUITopLevelWindows.FrameThatResizes ):
+@@ -476,7 +476,7 @@ class FrameGUI( ClientGUITopLevelWindows.FrameThatResizes ):
python_executable = python_executable.replace( 'pythonw', 'python' )
-- subprocess.Popen( [ python_executable, os.path.join( HC.BASE_DIR, 'server.py' ), db_dir ] )
-+ subprocess.Popen( [ python_executable, '/opt/hydrus/server.py', db_dir ] )
+- server_script_path = os.path.join( HC.BASE_DIR, 'server.py' )
++ server_script_path = '/opt/hydrus/server.py'
+
+ cmd = '"' + python_executable + '" "' + server_script_path + '" ' + db_param
-
- time_waited = 0
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index 7565ea3..74fe741 100755
+index bb0a939..8e690e1 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
@@ -3,30 +3,15 @@ import sys