summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2023-04-23 17:50:57 +0100
committerScore_Under2023-04-23 17:50:57 +0100
commitca2843a6ed0485154003bb2c09fabc8ea2ea10f8 (patch)
tree37a84050a3430d06788e482b6fededd86da4a05b
parent58c939e8b9ed0722ed4ca3a20ce51cc0c76ebe8e (diff)
downloadaur-ca2843a6ed0485154003bb2c09fabc8ea2ea10f8.tar.gz
Add swftools optdep and swfrender symlink
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 876a79b12873..88c6bcbdfc93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,8 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'desktop-file-utils: to add Hydrus to your desktop environment menus'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-pyqt6-charts: display bandwidth usage charts'
- 'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
+ 'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS'
+ 'swftools: to display SWF thumbnails')
source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=43ae2c2593c8e900b40460191b8379229578f52c"
paths-in-opt.patch
hydrus-client
@@ -81,6 +82,7 @@ package() {
install -d -m755 "${pkgdir}/opt/hydrus/bin"
ln -s /usr/bin/upnpc "${pkgdir}/opt/hydrus/bin/upnpc_linux"
ln -s /usr/bin/ffmpeg "${pkgdir}/opt/hydrus/bin/ffmpeg"
+ ln -s /usr/bin/swfrender "${pkgdir}/opt/hydrus/bin/swfrender_linux"
# Install hydrus-client and hydrus-server executables
install -d -m755 "${pkgdir}/usr/bin"