summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2023-11-30 18:09:00 +0000
committerScore_Under2023-11-30 18:09:00 +0000
commite751b21fbf0183704364e761c14adf64f29b0725 (patch)
tree28ab3251375383e7331f081ddeae7a0773bbd238
parentbb8a2085d6adf1615fecba17a66ea74dce7bdb01 (diff)
downloadaur-e751b21fbf0183704364e761c14adf64f29b0725.tar.gz
Update for v554
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch16
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f7e6961c2f9..69c721dac5dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 553
+ pkgver = 554
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
arch = any
@@ -45,13 +45,13 @@ pkgbase = hydrus
optdepends = swftools: to display SWF thumbnails
conflicts = hydrus-docs-dummy
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=304830d547bae1e0e6ec18cd956a17c2b5833d5e
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=efdfef46376fadee9a07412eaab039006d44a162
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = c332728ca119b1ed4e9a4f40de79087fa90f8754535718b506954d375541f9f0
+ sha256sums = 60411b8253db6a6f996d13701330ed76da44af4ce286d7c19276d85dbc7317fa
sha256sums = 39d3404b75320be6a9e33dc256f4fc313c65fe11458e96bd5af6268c2f78eaf0
sha256sums = 5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index d88e6560e466..6ed7df40f6b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ options=(!strip) # Don't strip libs because there aren't any
pkgname=hydrus
_pkgname=hydrus
-pkgver=553
+pkgver=554
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -37,13 +37,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
# 'speedcopy: may speed up file transfers'
'swftools: to display SWF thumbnails')
conflicts=(hydrus-docs-dummy)
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=304830d547bae1e0e6ec18cd956a17c2b5833d5e"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=efdfef46376fadee9a07412eaab039006d44a162"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- 'c332728ca119b1ed4e9a4f40de79087fa90f8754535718b506954d375541f9f0'
+ '60411b8253db6a6f996d13701330ed76da44af4ce286d7c19276d85dbc7317fa'
'39d3404b75320be6a9e33dc256f4fc313c65fe11458e96bd5af6268c2f78eaf0'
'5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 0c80dc15c19c..8a0b5244f38e 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index 2d2db51a..6096f3ec 100644
+index 62a61e1f..34b2506a 100644
--- a/hydrus/client/gui/ClientGUI.py
+++ b/hydrus/client/gui/ClientGUI.py
-@@ -6153,7 +6153,7 @@ class FrameGUI( CAC.ApplicationCommandProcessorMixin, ClientGUITopLevelWindows.M
+@@ -6213,7 +6213,7 @@ class FrameGUI( CAC.ApplicationCommandProcessorMixin, ClientGUITopLevelWindows.M
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -12,7 +12,7 @@ index 2d2db51a..6096f3ec 100644
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
-index 35765379..bbe24f67 100644
+index d59bf1aa..8cbf8fee 100644
--- a/hydrus/core/HydrusConstants.py
+++ b/hydrus/core/HydrusConstants.py
@@ -11,34 +11,9 @@ import yaml
@@ -53,7 +53,7 @@ index 35765379..bbe24f67 100644
muh_platform = sys.platform.lower()
-@@ -66,32 +41,16 @@ elif RUNNING_FROM_FROZEN_BUILD:
+@@ -69,34 +44,18 @@ elif RUNNING_FROM_FROZEN_BUILD:
elif RUNNING_FROM_MACOS_APP:
NICE_RUNNING_AS_STRING = 'from App'
@@ -76,8 +76,7 @@ index 35765379..bbe24f67 100644
-
- desired_userpath_db_dir = os.path.join( '~', 'Hydrus' )
-
-+USERPATH_DB_DIR = DEFAULT_DB_DIR
-
+-
-USERPATH_DB_DIR = os.path.expanduser( desired_userpath_db_dir )
-
-if USERPATH_DB_DIR == desired_userpath_db_dir:
@@ -86,7 +85,10 @@ index 35765379..bbe24f67 100644
-
- USERPATH_DB_DIR = None
-
--
++USERPATH_DB_DIR = DEFAULT_DB_DIR
+
+ WE_SWITCHED_TO_USERPATH = False
+
-LICENSE_PATH = os.path.join( BASE_DIR, 'license.txt' )
+LICENSE_PATH = "/usr/share/licenses/hydrus/license.txt"