summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Janošev2015-11-14 01:47:25 +0100
committerIgor Janošev2015-11-14 01:47:25 +0100
commita816c8abba262269353adfcac41fe1eb4282d06b (patch)
tree051278eb369bf335cf586f717e8d0543aa23ef1c
downloadaur-hyphen-sr.tar.gz
Add the initial files
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eda66847e951
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hyphen-sr
+ pkgdesc = Serbian Cyrillic and Latin hyphen dictionaries
+ pkgver = 20151113
+ pkgrel = 1
+ url = https://github.com/grakic/hyphen-sr
+ arch = any
+ license = GPL
+ license = LGPL
+ license = MPL
+ license = CC BY-SA 3.0 Unported
+ optdepends = hyphen: library for high quality hyphenation and justification
+ source = hyphen-sr-20151113.tar.gz::https://github.com/grakic/hyphen-sr/archive/4edd9b13ed7f4484658dea5bde5aa1d920dabe4a.tar.gz
+ sha1sums = 4e8d3ca5065ff98ef63b0d200e469aa7e0222927
+
+pkgname = hyphen-sr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..018ba1d2f972
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Igor Janošev <igor.janosev at outlook dot com>
+
+pkgname=hyphen-sr
+pkgver=20151113
+_git=4edd9b13ed7f4484658dea5bde5aa1d920dabe4a
+pkgrel=1
+pkgdesc="Serbian Cyrillic and Latin hyphen dictionaries"
+arch=(any)
+url="https://github.com/grakic/hyphen-sr"
+license=('GPL' 'LGPL' 'MPL' 'CC BY-SA 3.0 Unported')
+optdepends=('hyphen: library for high quality hyphenation and justification')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/grakic/hyphen-sr/archive/${_git}.tar.gz")
+sha1sums=('4e8d3ca5065ff98ef63b0d200e469aa7e0222927')
+
+package() {
+ cd "${srcdir}/${pkgname}-${_git}"
+ install -dm755 ${pkgdir}/usr/share/hyphen
+ install -m644 hyph_sr.dic hyph_sr-Latn.dic ${pkgdir}/usr/share/hyphen
+
+ pushd ${pkgdir}/usr/share/hyphen
+ mv hyph_sr.dic hyph_sr_RS.dic
+ mv hyph_sr-Latn.dic hyph_sr_Latn_RS.dic
+ popd
+
+ # docs
+ install -dm755 ${pkgdir}/usr/share/doc/${pkgname}
+ install -m644 README*.txt ${pkgdir}/usr/share/doc/${pkgname}
+
+ # licenses
+ install -D -m644 README.txt ${pkgdir}/usr/share/licenses/${pkgname}/Copyright
+ install -D -m644 README_sr.txt ${pkgdir}/usr/share/licenses/${pkgname}/Copyright_sr
+ install -D -m644 README-sr-Latn.txt ${pkgdir}/usr/share/licenses/${pkgname}/Copyright_sr-Latn
+}