summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortohmais2023-03-04 12:57:23 +1000
committertohmais2023-03-04 12:57:23 +1000
commit0bfc5ba8d42f29eccd2d3119e06a32b4ff840492 (patch)
treead2daea7d7533a4cc0e3dbc6bc07cb11b7008e2f
parentd640892cb253d4a99ba170277a235b54cdc00e5d (diff)
downloadaur-0bfc5ba8d42f29eccd2d3119e06a32b4ff840492.tar.gz
readd screenshare patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--nvidia.patch28
3 files changed, 32 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 838ce4ddff6a..4c5bf1d0c391 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-nvidia-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)
- pkgver = r2550.31cd1042
+ pkgver = r2551.c4440993
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = any
@@ -52,6 +52,6 @@ pkgbase = hyprland-nvidia-git
source = hyprland::git+https://github.com/hyprwm/Hyprland.git
source = nvidia.patch
sha256sums = SKIP
- sha256sums = c200d341641ee20a13b1893e27a9d823e9ef5ac2378e3cdecd0efc55a713db1c
+ sha256sums = b412eb6040cf7406d20fe9941e8a08f2a314ec4d4ec305fca9f12ac2b0280737
pkgname = hyprland-nvidia-git
diff --git a/PKGBUILD b/PKGBUILD
index 1de440f59077..f069296affed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-nvidia-git"
-pkgver=r2550.31cd1042
+pkgver=r2551.c4440993
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)"
arch=(any)
@@ -54,7 +54,7 @@ source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
conflicts=("${_pkgname}")
provides=(hyprland)
sha256sums=('SKIP'
- 'c200d341641ee20a13b1893e27a9d823e9ef5ac2378e3cdecd0efc55a713db1c')
+ 'b412eb6040cf7406d20fe9941e8a08f2a314ec4d4ec305fca9f12ac2b0280737')
options=(!makeflags !buildflags !strip)
pkgver() {
diff --git a/nvidia.patch b/nvidia.patch
index 6abd4de2d209..38da095da505 100644
--- a/nvidia.patch
+++ b/nvidia.patch
@@ -9,3 +9,31 @@ diff --unified --recursive --text hyprland-test/src/hyprland/subprojects/wlroots
+ glFinish();
glBindFramebuffer(GL_FRAMEBUFFER, 0);
pop_gles2_debug(renderer);
+
+diff --unified --recursive --text hyprland-test/src/hyprland/subprojects/wlroots/types/output/render.c hyprland-git/src/hyprland/subprojects/wlroots/types/output/render.c
+--- types/output/render.c 2022-10-23 11:18:56.598893482 +1000
++++ types/output/render.c 2022-10-23 11:15:15.110308366 +1000
+@@ -325,22 +325,7 @@
+ }
+
+ uint32_t wlr_output_preferred_read_format(struct wlr_output *output) {
+- struct wlr_renderer *renderer = output->renderer;
+- assert(renderer != NULL);
+-
+- if (!renderer->impl->preferred_read_format || !renderer->impl->read_pixels) {
+- return DRM_FORMAT_INVALID;
+- }
+-
+- if (!output_attach_back_buffer(output, &output->pending, NULL)) {
+- return false;
+- }
+-
+- uint32_t fmt = renderer->impl->preferred_read_format(renderer);
+-
+- output_clear_back_buffer(output);
+-
+- return fmt;
++ return DRM_FORMAT_XRGB8888;
+ }
+
+ bool output_is_direct_scanout(struct wlr_output *output, \ No newline at end of file