summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhafeoz2023-03-04 18:26:04 +0000
committerhafeoz2023-03-04 18:26:04 +0000
commite2240fe98bc78bed61bbeeda5eff9e267a5d77a6 (patch)
tree5222758cb8b586f5d5c40934359c3fed9fe3c9b3
parentb4c7406e00645c7d1ec6da0be291e0d126f9c77c (diff)
downloadaur-e2240fe98bc78bed61bbeeda5eff9e267a5d77a6.tar.gz
fix: add missing depedencies and fix build function
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e89daf275166..79ea22bb0426 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-nvidia-hidpi-git"
-pkgver=r2042.ga7ed3a5
+pkgver=r2551.c4440993
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA + HiDPI patch)"
arch=(any)
@@ -37,7 +37,8 @@ depends=(
seatd
vulkan-icd-loader
vulkan-validation-layers
- xorg-xwayland-hidpi-xprop)
+ xorg-xwayland-hidpi-xprop
+ libdisplay-info)
makedepends=(
git
cmake
@@ -89,6 +90,7 @@ build() {
cd "${srcdir}/${_pkgname}"
make fixwlr
cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../../
+ cd subprojects/udis86 && cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=Release -H./ -B./build -G Ninja && cmake --build ./build --config Release --target all -j$(shell nproc) && cd ../../
make protocols
make release
cd ./hyprctl && make all && cd ..