summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Erik Rediger2015-06-09 16:15:31 +0200
committerJan-Erik Rediger2015-06-09 16:15:31 +0200
commit520bcc1e31f76ea49ba2650c15db59ee31cc9785 (patch)
treec0ecd7a734e76d9eaf79969ace5c6cfb6ea611f9
downloadaur-i3-ipc.tar.gz
First commit in new AUR
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--i3-ipc.install11
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd53269683e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = i3-ipc
+ pkgdesc = inter-process communication with i3, the improved tiling window manager.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://github.com/badboy/i3-ipc
+ install = i3-ipc.install
+ arch = any
+ license = custom
+ depends = i3-wm
+ depends = ruby
+ source = http://github.com/badboy/i3-ipc/raw/v0.2.0/i3-ipc
+ source = http://github.com/badboy/i3-ipc/raw/v0.2.0/man/i3-ipc.1
+ source = http://github.com/badboy/i3-ipc/raw/v0.2.0/LICENSE
+ md5sums = 7696d0e53ebfb3a261e20b1b39e4c71d
+ md5sums = 971bfaa7d5aff297eff60cd17c93a08d
+ md5sums = 2fde1ca125088725e39018124051d000
+
+pkgname = i3-ipc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ea9ede72329
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jan-Erik Rediger <badboy at archlinux dot us>
+pkgname=i3-ipc
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="inter-process communication with i3, the improved tiling window manager."
+arch=(any)
+url="http://github.com/badboy/i3-ipc"
+license=('custom')
+depends=('i3-wm' 'ruby')
+source=(
+ "http://github.com/badboy/i3-ipc/raw/v${pkgver}/i3-ipc"
+ "http://github.com/badboy/i3-ipc/raw/v${pkgver}/man/i3-ipc.1"
+ "http://github.com/badboy/i3-ipc/raw/v${pkgver}/LICENSE"
+)
+install='i3-ipc.install'
+md5sums=('7696d0e53ebfb3a261e20b1b39e4c71d'
+ '971bfaa7d5aff297eff60cd17c93a08d'
+ '2fde1ca125088725e39018124051d000')
+
+build() {
+ cd "$srcdir/"
+
+ install -Dm755 i3-ipc \
+ ${pkgdir}/usr/bin/i3-ipc || return 1
+
+ install -Dm644 i3-ipc.1 \
+ ${pkgdir}/usr/share/man/man1/i3-ipc.1 || return 1
+
+ install -Dm644 LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/i3-ipc.install b/i3-ipc.install
new file mode 100644
index 000000000000..aafe8585c04b
--- /dev/null
+++ b/i3-ipc.install
@@ -0,0 +1,11 @@
+## arg 1: the new package version
+post_install() {
+ echo
+ echo '---------------------------------------------------------------------------'
+ echo ' IMPORTANT NOTES:'
+ echo
+ echo 'You need eventmachine to run the latest version of i3-ipc'
+ echo 'Install it via gem:'
+ echo ' $ gem install eventmachine'
+ echo "---------------------------------------------------------------------------"
+}