summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbud2020-08-11 18:56:24 +0200
committerbud2020-08-11 18:56:24 +0200
commit18a3e15ccc1f602bca33aac2e7615b946815f108 (patch)
treecc32289a41737245e4ea46447e0ba96c2e5f0940
parent169515f31375c788af60e3ff5aa66ac36fad9b36 (diff)
downloadaur-18a3e15ccc1f602bca33aac2e7615b946815f108.tar.gz
updated to new version added rofi to optdepends and good source url
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9783aa75b964..cc5f6a8fe1a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = i3ass
pkgdesc = A bash-script collection to assist the use of i3-wm.
- pkgver = 2020.01.26.6
+ pkgver = 2020.08.11.1
pkgrel = 1
url = https://github.com/budlabs/i3ass
arch = any
license = MIT
depends = bash>=4.0.0
- optdepends = xdotool: floating window placement
- optdepends = i3-wm: duh
- source = https://github.com/budlabs/i3ass/archive/2020.01.26.6.tar.gz
- sha256sums = 10c6095ee760f8d66b5a47c21872f2c93d9d30fd106e41b0a4c341dcffeb1b2e
+ depends = i3-wm
+ depends = gawk
+ depends = sed
+ optdepends = rofi
+ optdepends = xdotool
+ source = https://github.com/budlabs/i3ass/archive/2020.08.11.1/i3ass-2020.08.11.1.tar.gz
+ sha256sums = a31b332ff5c4884f02dc4ae9bc34e111857920cc969e62e466b6967cd4d567b3
pkgname = i3ass
diff --git a/PKGBUILD b/PKGBUILD
index a5c75bead3c8..77930c0e289a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: Nils Kvist <robstenklippa@gmail.com>
-# Contributor: Nils Kvist <robstenklippa@gmail.com>
+# Maintainer: budRich
+# Contributor: budRich
pkgname=i3ass
-pkgver=2020.01.26.6
+pkgver=2020.08.11.1
pkgrel=1
pkgdesc='A bash-script collection to assist the use of i3-wm.'
arch=('any')
url='https://github.com/budlabs/i3ass'
license=('MIT')
groups=()
-depends=('bash>=4.0.0')
+depends=('bash>=4.0.0' 'i3-wm' 'gawk' 'sed')
makedepends=()
-optdepends=('xdotool: floating window placement' 'i3-wm: duh')
+optdepends=('rofi' 'xdotool')
provides=()
conflicts=()
replaces=()
@@ -19,14 +19,13 @@ backup=()
options=()
install=
changelog=
-source=("$url/archive/$pkgver.tar.gz")
+source=("$url/archive/$pkgver/${pkgname}-$pkgver.tar.gz")
noextract=()
-sha256sums=('10c6095ee760f8d66b5a47c21872f2c93d9d30fd106e41b0a4c341dcffeb1b2e')
+sha256sums=('a31b332ff5c4884f02dc4ae9bc34e111857920cc969e62e466b6967cd4d567b3')
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" PREFIX=/usr uninstall
make DESTDIR="$pkgdir/" PREFIX=/usr install
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE