summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Lindroth2022-10-24 19:12:32 +0200
committerRasmus Lindroth2022-10-24 19:12:32 +0200
commit7be123a56d54f5a885e117c0cd97d47541df08d3 (patch)
tree8170c2105e6c48ea155fc150275ef5d2843313d3
parentc328054f49329a484a531e0cdc8e7fd7f364ae08 (diff)
downloadaur-i3keys.tar.gz
minor fixes and alt to mod1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0aa3d25bb1f4..dcd3075ef9fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = i3keys
pkgdesc = Lists used and unused keys in your i3wm or Sway config
- pkgver = 0.0.15
+ pkgver = 0.0.16
pkgrel = 1
url = https://github.com/RasmusLindroth/i3keys
- arch = any
+ arch = x86_64
license = MIT
makedepends = go
- source = https://github.com/RasmusLindroth/i3keys/archive/refs/tags/0.0.15.tar.gz
- sha256sums = 88288f97bace967018a885b5e7b4347ef5f59c013f388f316261c99c460a22ad
+ makedepends = libxtst
+ depends = libx11
+ options = !lto
+ source = i3keys-0.0.16.tar.gz::https://github.com/RasmusLindroth/i3keys/archive/refs/tags/0.0.16.tar.gz
+ sha256sums = 7169e9e75baff083555e581808a073a7b05959d2c75ff021118b71b3e8ce7787
pkgname = i3keys
diff --git a/PKGBUILD b/PKGBUILD
index f1949e0498c7..88a7d1891b6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
# Maintainer: Rasmus Lindroth <rasmus@lindroth.xyz>
pkgname=i3keys
-pkgver=0.0.15
+pkgver=0.0.16
pkgrel=1
pkgdesc='Lists used and unused keys in your i3wm or Sway config'
-arch=('any')
+arch=('x86_64')
url="https://github.com/RasmusLindroth/$pkgname"
license=('MIT')
-makedepends=('go')
-source=("https://github.com/RasmusLindroth/$pkgname/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('88288f97bace967018a885b5e7b4347ef5f59c013f388f316261c99c460a22ad')
+options=(!lto)
+depends=('libx11')
+makedepends=('go' 'libxtst')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RasmusLindroth/$pkgname/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('7169e9e75baff083555e581808a073a7b05959d2c75ff021118b71b3e8ce7787')
build() {
- cd $pkgname-$pkgver
- go build \
- -gcflags "all=-trimpath=$PWD" \
- -asmflags "all=-trimpath=$PWD" \
- -ldflags "-extldflags $LDFLAGS" \
- -o $pkgname .
+ cd $pkgname-$pkgver
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o .
}
package() {
- cd $pkgname-$pkgver
- install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ cd $pkgname-$pkgver
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
}