summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeskarune2016-04-16 13:50:29 -0400
committermeskarune2016-04-16 13:50:29 -0400
commit3875009ae4a58257dd1f7208d8dd657b7c2f9346 (patch)
treee4afb8a49fb2ae78c409fc7de7f1a3cd74d73d46
parent0cb381cc1e851e84b19f0a77f6ac9d3d0e485391 (diff)
downloadaur-3875009ae4a58257dd1f7208d8dd657b7c2f9346.tar.gz
fixed pkgbuild so it works with dirs that have spaces
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c35f401a6bd9..fb3b4cce1755 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Apr 14 01:19:17 UTC 2016
+# Sat Apr 16 17:50:12 UTC 2016
pkgbase = i3lock-fancy-git
pkgdesc = i3lock-color script: blurs background, adds lock icon and text, offers dark/light background detection.
pkgver = r78.8e6f9f4
@@ -18,7 +18,9 @@ pkgbase = i3lock-fancy-git
depends = scrot
provides = i3lock-fancy
source = git+https://github.com/meskarune/i3lock-fancy.git
+ source = package.patch
md5sums = SKIP
+ md5sums = b7493e6bb3ce1129e0f23f18c4e9480f
pkgname = i3lock-fancy-git
diff --git a/PKGBUILD b/PKGBUILD
index 4c7c3594c6a2..b3b4069a4092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,15 +11,16 @@ license=('MIT')
depends=('coreutils' 'awk' 'bash' 'util-linux' 'imagemagick' 'i3lock' 'scrot')
makedepends=('git')
provides=("i3lock-fancy")
-source=("git+https://github.com/meskarune/$_gitname.git")
-md5sums=('SKIP')
+source=("git+https://github.com/meskarune/$_gitname.git" "package.patch")
+md5sums=('SKIP'
+ 'b7493e6bb3ce1129e0f23f18c4e9480f')
pkgver() {
cd "$_gitname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- patch -N "${srcdir}"/"${_gitname}"/lock ../package.patch
+ patch -N "${srcdir}"/"${_gitname}"/lock "${srcdir}"/package.patch
}
package() {
cd "${srcdir}"/"$_gitname"