summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-06-12 17:10:06 -0700
committerxiota2023-06-12 17:10:06 -0700
commitbf06ad85019daf31fdb0f1c0340bda473610ee90 (patch)
tree56a4f575f786edeeab869c9ff91cce23dc9e8a3c
parenteef4fef480ab8139a158d6c2688a302bdf24c5a9 (diff)
downloadaur-bf06ad85019daf31fdb0f1c0340bda473610ee90.tar.gz
update python packaging
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
3 files changed, 41 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2add793a50b3..8aa5a055c9c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = ialauncher-git
- pkgdesc = Play all of the Internet Archive’s MS-DOS games offline!
+ pkgdesc = Play all of the Internet Archive’s MS-DOS games offline
pkgver = r127.b93f75d
- pkgrel = 2
+ pkgrel = 1
url = https://github.com/rtts/ialauncher
- arch = x86_64
+ arch = any
license = GPL3
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- depends = dosbox
- depends = webkit2gtk
- depends = python
- depends = python-natsort
- depends = gst-plugins-bad
- depends = python-jinja
- source = ialauncher::git+https://github.com/rtts/ialauncher.git
+ makedepends = python-wheel
+ depends = python-pygame
+ source = ialauncher::git+https://github.com/rtts/ialauncher
sha256sums = SKIP
pkgname = ialauncher-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 1fc3bd556bad..c4efdf7ede66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,45 @@
-# Maintainer: gee
+# Maintainer:
+# Contributor: gee
-pkgname=ialauncher-git
+_pkgname="ialauncher"
+pkgname="$_pkgname-git"
pkgver=r127.b93f75d
-pkgrel=2
-pkgdesc='Play all of the Internet Archive’s MS-DOS games offline!'
-arch=('x86_64')
+pkgrel=1
+pkgdesc='Play all of the Internet Archive’s MS-DOS games offline'
+arch=('any')
url='https://github.com/rtts/ialauncher'
license=('GPL3')
-depends=('dosbox' 'webkit2gtk' 'python' 'python-natsort' 'gst-plugins-bad'
- 'python-jinja')
-makedepends=('git' 'python-setuptools')
-source=('ialauncher::git+https://github.com/rtts/ialauncher.git')
+depends=(
+ 'python-pygame'
+
+ # Not needed?
+ #'dosbox'
+ #'gst-plugins-bad'
+ #'python-jinja'
+ #'python-natsort'
+ #'webkit2gtk'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
+source=("$_pkgname"::"git+$url")
sha256sums=('SKIP')
pkgver() {
- cd ialauncher
-
+ cd "$srcdir/$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd ialauncher
-
- python setup.py build
+ cd "$srcdir/$_pkgname"
+ python -m build --no-isolation --wheel
}
package() {
cd ialauncher
-
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}