summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël PORTAY2024-04-09 18:35:21 +0200
committerGaël PORTAY2024-04-09 18:35:21 +0200
commit1761176adf2008e8fa87f7d6f205cf5610448c54 (patch)
tree5be0e38a9d651b99fead12853a81446feaa731b8
parent084ae122bb6aa3ebc9e6fdd912ecc21c42d7034f (diff)
downloadaur-iamroot-armhf.tar.gz
v21
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2aee6cbf7b06..63bcb692c373 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = iamroot-armhf
pkgdesc = Emulating the syscall chroot(2) in an unpriviliged process (armhf)
- pkgver = 20
+ pkgver = 21
pkgrel = 1
url = https://github.com/gportay/iamroot
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = iamroot-armhf
makedepends = patchelf
makedepends = asciidoctor
options = !strip
- source = https://github.com/gportay/iamroot/archive/v20.tar.gz
+ source = https://github.com/gportay/iamroot/archive/v21.tar.gz
validpgpkeys = 8F3491E60E62695ED780AC672FA122CA0501CA71
- sha256sums = 27c3019135fce9359a7e7ff6abb0501108c4881e6c57609f4c14d0fb91f17eec
+ sha256sums = 3bbdc8b53a4e1e0a88d2aa281fd85bd4e3653c7634060d6b7442c932dae03b07
pkgname = iamroot-armhf
diff --git a/PKGBUILD b/PKGBUILD
index 6aebac3b285c..3e06a6aa6041 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gaël PORTAY <gael.portay@gmail.com>
pkgname=iamroot-armhf
-pkgver=20
+pkgver=21
pkgrel=1
pkgdesc='Emulating the syscall chroot(2) in an unpriviliged process (armhf)'
arch=('x86_64')
@@ -15,7 +15,7 @@ makedepends=('armv7-eabihf-glibc-bleeding-edge-toolchain'
checkdepends=('shellcheck')
options=('!strip')
source=("https://github.com/gportay/${pkgname%-armhf}/archive/v$pkgver.tar.gz")
-sha256sums=('27c3019135fce9359a7e7ff6abb0501108c4881e6c57609f4c14d0fb91f17eec')
+sha256sums=('3bbdc8b53a4e1e0a88d2aa281fd85bd4e3653c7634060d6b7442c932dae03b07')
validpgpkeys=('8F3491E60E62695ED780AC672FA122CA0501CA71')
prepare() {
@@ -26,8 +26,8 @@ prepare() {
build() {
cd "${pkgname%-armhf}-$pkgver"
- make CFLAGS= PREFIX=/usr armhf/libiamroot-linux-armhf.so.3
- make CFLAGS= PREFIX=/usr armhf/libiamroot-musl-armhf.so.1
+ make CFLAGS=-DJIM_REGEXP PREFIX=/usr armhf/libiamroot-linux-armhf.so.3
+ make CFLAGS=-DJIM_REGEXP PREFIX=/usr armhf/libiamroot-musl-armhf.so.1
}
check() {
@@ -39,5 +39,6 @@ package() {
cd "${pkgname%-armhf}-$pkgver"
make PREFIX=/usr DESTDIR="$pkgdir" install-exec-armhf-linux-armhf.3
make PREFIX=/usr DESTDIR="$pkgdir" install-exec-armhf-musl-armhf.1
+ make PREFIX=/usr DESTDIR="$pkgdir" install-support-armhf
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}