summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2015-07-07 23:24:30 +0200
committerGeorg Schlisio2015-07-07 23:24:30 +0200
commit685042f80f73b07efa9c5e04aacc91a7e493fc5a (patch)
treea51a54b5c0e3ee024d77f33f4998be14fc727be9
downloadaur-685042f80f73b07efa9c5e04aacc91a7e493fc5a.tar.gz
13.1.0.285639, moved from aur3
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD114
-rw-r--r--citrix-client.install46
-rw-r--r--configmgr.desktop10
-rw-r--r--conncenter.desktop10
-rw-r--r--selfservice.desktop9
-rw-r--r--wfica.desktop12
-rwxr-xr-xwfica.sh3
-rwxr-xr-xwfica_assoc.sh3
9 files changed, 254 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be95b06ef9c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+pkgbase = icaclient
+ pkgdesc = Citrix Receiver for Linux (ICAClient)
+ pkgver = 13.1.0.285639
+ pkgrel = 10
+ url = http://www.citrix.com/English/ps2/products/product.asp?contentID=1689163&ntref=prod_top
+ install = citrix-client.install
+ arch = x86_64
+ license = custom:Citrix
+ makedepends = wget
+ depends = alsa-lib
+ depends = libvorbis
+ depends = curl
+ depends = gtk2
+ depends = libpng12
+ depends = libxml2
+ depends = libxaw
+ depends = libxext
+ depends = libxft
+ depends = libxinerama
+ depends = libxmu
+ depends = libxp
+ depends = libxpm
+ depends = libxt
+ depends = ca-certificates
+ depends = nspluginwrapper
+ optdepends = xerces-c: gtk2 configuration manager
+ optdepends = webkitgtk2: gtk2 selfservice/storefront ui
+ conflicts = bin32-citrix-client
+ conflicts = citrix-client
+ options = !strip
+ source = configmgr.desktop
+ source = conncenter.desktop
+ source = selfservice.desktop
+ source = wfica.desktop
+ source = wfica.sh
+ source = wfica_assoc.sh
+ source = icaclient-13.1.0.285639.tar.gz::http://downloads.citrix.com/9819/linuxx64-13.1.0.285639.tar.gz?__gda__=1436307928_1b84d128f260b9d7ee727ebba854e53f
+ md5sums = 71aca6257f259996ac59729604f32978
+ md5sums = a38c3f844a0fefe8017a25bee213b843
+ md5sums = 0e92c33b3fcc99b04269787da2984809
+ md5sums = 1f214f6f456f59afd1a3275580f4240e
+ md5sums = 59f8e50cc0e0c399d47eb7ace1df5a32
+ md5sums = dca5a1f51449ef35f1441b900d622276
+ md5sums = afa8d0ba96e38f92709c483b54698e12
+
+pkgname = icaclient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b1e14c8f641
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,114 @@
+# Maintainer: Daniele Vazzola <daniele.vazzola@gmail.com>
+# Contributor: CiarĂ¡n Coffey <ciaran@ccoffey.ie>
+# Contributor: Matthew Gyurgyik <matthew@pyther.net>
+pkgname=icaclient
+pkgver=13.1.0.285639
+pkgrel=10
+pkgdesc="Citrix Receiver for Linux (ICAClient)"
+arch=('x86_64')
+url="http://www.citrix.com/English/ps2/products/product.asp?contentID=1689163&ntref=prod_top"
+license=('custom:Citrix')
+depends=(
+ 'alsa-lib'
+ 'libvorbis'
+ 'curl'
+ 'gtk2'
+ 'libpng12'
+ 'libxml2'
+ 'libxaw'
+ 'libxext'
+ 'libxft'
+ 'libxinerama'
+ 'libxmu'
+ 'libxp'
+ 'libxpm'
+ 'libxt'
+ 'ca-certificates'
+ 'nspluginwrapper'
+)
+optdepends=(
+ 'xerces-c: gtk2 configuration manager'
+ 'webkitgtk2: gtk2 selfservice/storefront ui'
+)
+
+conflicts=('bin32-citrix-client' 'citrix-client')
+options=(!strip)
+
+source_url="http:$(curl -L -silent 'http://www.citrix.com/downloads/citrix-receiver/linux/receiver-for-linux-131.html' | awk -F 'rel=\"' '/linuxx64-/ {print $2}'| awk -F'"' '{print $1}'| sed '/^$/d' |uniq)"
+source=('configmgr.desktop' 'conncenter.desktop' 'selfservice.desktop' 'wfica.desktop' 'wfica.sh' 'wfica_assoc.sh' $pkgname-$pkgver.tar.gz::$source_url)
+makedepends=('wget')
+md5sums=('71aca6257f259996ac59729604f32978'
+ 'a38c3f844a0fefe8017a25bee213b843'
+ '0e92c33b3fcc99b04269787da2984809'
+ '1f214f6f456f59afd1a3275580f4240e'
+ '59f8e50cc0e0c399d47eb7ace1df5a32'
+ 'dca5a1f51449ef35f1441b900d622276'
+ 'afa8d0ba96e38f92709c483b54698e12')
+
+
+install=citrix-client.install
+
+package() {
+ cd "${srcdir}"
+ ICAROOT=/opt/Citrix/ICAClient
+
+ mkdir -p ${pkgdir}$ICAROOT
+
+ cd "$srcdir/linuxx64/linuxx64.cor"
+ install -m755 wfica *.so *.DLL AuthManagerDaemon PrimaryAuthManager ServiceRecord selfservice ${pkgdir}$ICAROOT
+
+ # copy directories
+ cp -r ./config/ ${pkgdir}$ICAROOT
+ cp -r ./gtk/ ${pkgdir}$ICAROOT
+ cp -r ./help/ ${pkgdir}$ICAROOT
+ cp -r ./keyboard/ ${pkgdir}$ICAROOT
+ cp -r ./keystore/ ${pkgdir}$ICAROOT
+ cp -r ./lib/ ${pkgdir}$ICAROOT
+ cp -r ./icons/ ${pkgdir}$ICAROOT
+ cp -r ./nls/ ${pkgdir}$ICAROOT
+ cp -r ./site/ ${pkgdir}$ICAROOT
+ cp -r ./usb/ ${pkgdir}$ICAROOT
+ cp -r ./util/ ${pkgdir}$ICAROOT
+
+ # Intall License
+ install -m644 -D nls/en/eula.txt \
+ "${pkgdir}$ICAROOT/eula.txt"
+
+ # create /config/.server to enable user customization using ~/.ICACLient/ overrides. Thanks Tomek
+ touch ${pkgdir}$ICAROOT/config/.server
+
+ # Extract system ca-certificates and install in the Citrix cacerts directory
+ cp /etc/ca-certificates/extracted/tls-ca-bundle.pem ${pkgdir}$ICAROOT/keystore/cacerts/
+ cd ${pkgdir}$ICAROOT/keystore/cacerts/
+ awk 'BEGIN {c=0;} /BEGIN CERT/{c++} { print > "cert." c ".pem"}' < tls-ca-bundle.pem
+
+ # The following 32-bit library causes false namcap errors
+ # rm util/libgstflatstm.32.so
+
+ # Install wrapper script
+ install -m755 ${srcdir}/wfica.sh ${pkgdir}$ICAROOT/wfica.sh
+
+ # Dirty Hack
+ # wfica expects {module,wfclient,apssrv}.ini in $ICAROOT/config
+ # sadly these configs differ slightly by locale
+ lang=${LANG%%_*}
+ if [[ ! -d ${pkgdir}/$ICAROOT/nls/$lang ]]; then
+ lang='en'
+ fi
+ cp ${pkgdir}/$ICAROOT/nls/$lang/{appsrv.ini,module.ini,wfclient.ini} ${pkgdir}/$ICAROOT/config/
+
+# Copy Firefox plugin into plugin directory
+ mkdir -p "${pkgdir}/usr/lib/mozilla/plugins"
+ ln -s "$ICAROOT/npica.so" "${pkgdir}"/usr/lib/mozilla/plugins/npica.so
+ cd "${srcdir}"
+ # install freedesktop.org files
+ install -Dm644 wfica.desktop "${pkgdir}/usr/share/applications/wfica.desktop"
+ install -Dm644 conncenter.desktop "${pkgdir}/usr/share/applications/conncentre.desktop"
+ install -Dm644 configmgr.desktop "${pkgdir}/usr/share/applications/configmgr.desktop"
+ install -Dm644 selfservice.desktop "${pkgdir}/usr/share/applications/wfcmgr.desktop"
+ # install scripts
+ install -Dm755 wfica.sh "${pkgdir}$ICAROOT"
+ install -Dm755 wfica_assoc.sh "${pkgdir}$ICAROOT"
+
+}
+
diff --git a/citrix-client.install b/citrix-client.install
new file mode 100644
index 000000000000..e74d01cb096a
--- /dev/null
+++ b/citrix-client.install
@@ -0,0 +1,46 @@
+pre_install() {
+ tmpdir="/tmp"
+ instdir="/opt/Citrix/ICAClient"
+ configdir="${instdir}/config"
+
+ # If we already have citrix installed, we want to preserve the config files for the post_install question.
+ [ -e "${configdir}"/appsrv.ini ] && cp "${configdir}"/appsrv.ini ${tmpdir}/
+ [ -e "${configdir}"/wfclient.ini ] && cp "${configdir}"/wfclient.ini ${tmpdir}/
+ [ -e "${configdir}"/module.ini ] && cp "${configdir}"/module.ini ${tmpdir}/
+}
+
+post_install() {
+ instdir="/opt/Citrix/ICAClient"
+ tmpdir="/tmp"
+ nspluginwrapper -i /opt/Citrix/ICAClient/npica.so
+
+
+ echo "Should old the configuration files be taken into new build (y|N)?"
+ read choice
+ choice="`echo ${choice} | tr '[:upper:]' '[:lower:]'`"
+ #restore config files
+ if [[ "${choice}" == "y" ]]; then
+ echo "Copying old config files ..."
+ [ -e "${tmpdir}"/appsrv.ini ] && mv "${tmpdir}"/appsrv.ini "${instdir}"/config/ && echo " Copied 'appsrv.ini'"
+ [ -e "${tmpdir}"/wfclient.ini ] && mv "${tmpdir}"/wfclient.ini "${instdir}"/config/ && echo " Copied 'wfclient.ini'"
+ [ -e "${tmpdir}"/module.ini ] && mv "${tmpdir}"/module.ini "${instdir}"/config/ && echo " Copied 'module.ini'"
+ fi
+ chmod 666 "${instdir}"/config/{appsrv,wfclient,module}.ini
+ # symlink certificates
+ [ -d /usr/share/ca-certificates/mozilla ] && ln -s /usr/share/ca-certificates/mozilla/* ${instdir}/keystore/cacerts/ > /dev/null 2>&1
+ echo ""
+ echo "CA certs SymLinked for SSL support."
+ echo "All done."
+
+ echo -e "\e[1;31m\nYou have to create '\e[1;33m\$HOME/.ICAClient/cache\e[1;31m' for each user who uses this program and then populate it with the appropriate ini files. Copy paste the below to do this easily:\n"
+ echo -e "\e[1;37mmkdir -p \$HOME/.ICAClient/cache"
+ echo -e "cp ${instdir}/config/{All_Regions,Trusted_Region,Unknown_Region,canonicalization,regions}.ini \$HOME/.ICAClient/\n"
+ #echo -e "\e[1;37mFinally, set firefox to use the command '${firefox_command}' for .ICA files."
+ echo -e "\e[0m"
+
+ # add mimetype handler
+ update-desktop-database -q
+}
+
+pre_upgrade() { pre_install; }
+post_upgrade() { post_install; }
diff --git a/configmgr.desktop b/configmgr.desktop
new file mode 100644
index 000000000000..4a90a85410ea
--- /dev/null
+++ b/configmgr.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Name=Citrix Receiver Preferences
+NoDisplay=false
+Categories=Application;Network;X-Red-Hat-Base;X-SuSE-Core-Internet;
+Icon=/opt/Citrix/ICAClient/icons/manager.png
+TryExec=/opt/Citrix/ICAClient/util/configmgr
+Exec=/opt/Citrix/ICAClient/util/configmgr --icaroot /opt/Citrix/ICAClient
diff --git a/conncenter.desktop b/conncenter.desktop
new file mode 100644
index 000000000000..99e30c4a80bc
--- /dev/null
+++ b/conncenter.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Name=Citrix Connection Centre
+NoDisplay=false
+Categories=Application;Network;X-Red-Hat-Base;X-SuSE-Core-Internet;
+Icon=/opt/Citrix/ICAClient/icons/manager.png
+TryExec=/opt/Citrix/ICAClient/util/conncenter
+Exec=/opt/Citrix/ICAClient/util/conncenter --icaroot /opt/Citrix/ICAClient
diff --git a/selfservice.desktop b/selfservice.desktop
new file mode 100644
index 000000000000..c616036db2b8
--- /dev/null
+++ b/selfservice.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Name=Citrix Receiver Self Service
+Categories=Application;Network;X-Red-Hat-Base;X-SuSE-Core-Internet;
+Icon=/opt/Citrix/ICAClient/icons/manager.png
+TryExec=/opt/Citrix/ICAClient/selfservice
+Exec=/opt/Citrix/ICAClient/selfservice --icaroot /opt/Citrix/ICAClient
diff --git a/wfica.desktop b/wfica.desktop
new file mode 100644
index 000000000000..d1729ed871ae
--- /dev/null
+++ b/wfica.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Name=Citrix Receiver Engine
+StartupWMClass=Wfica
+NoDisplay=true
+Categories=Application;Network;X-Red-Hat-Base;X-SuSE-Core-Internet;
+MimeType=application/x-ica;
+Icon=/opt/Citrix/ICAClient/icons/manager.png
+TryExec=/opt/Citrix/ICAClient/wfica.sh
+Exec=/opt/Citrix/ICAClient/wfica.sh
diff --git a/wfica.sh b/wfica.sh
new file mode 100755
index 000000000000..261d552bf9f4
--- /dev/null
+++ b/wfica.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+export ICAROOT=/opt/Citrix/ICAClient
+${ICAROOT}/wfica -file "$1"
diff --git a/wfica_assoc.sh b/wfica_assoc.sh
new file mode 100755
index 000000000000..22dc2cc7bc7a
--- /dev/null
+++ b/wfica_assoc.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+export ICAROOT=/opt/Citrix/ICAClient
+${ICAROOT}/wfica -associate -fileparam "$1"