summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2024-02-05 23:45:35 +0200
committerAdrian Perez de Castro2024-02-05 23:45:35 +0200
commit0471892744a04e86ea712c9345bd16dc0ba97e27 (patch)
tree23abe1eff627ca93ec385991bafa06ab2c090619
parent0523a16768edd2c353739c72ceab2ac2e6574819 (diff)
downloadaur-icetop-git.tar.gz
Add missing git package in makedepends, use arch-meson
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f96adea8267..18fae2a46966 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = icetop-git
pkgdesc = Terminal top-like monitor for icecream/icecc
- pkgver = r37.48482f3
+ pkgver = r41.e782c8c
pkgrel = 1
url = https://github.com/aperezdc/icetop
arch = x86_64
@@ -8,11 +8,11 @@ pkgbase = icetop-git
license = GPL2
makedepends = meson
makedepends = ninja
+ makedepends = git
depends = icecream
depends = libdill
- depends = libtickit-bzr
+ depends = libtickit
source = icetop-git::git+https://github.com/aperezdc/icetop
sha512sums = SKIP
pkgname = icetop-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f074c3fbf87b..7323b3c6e8f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgdesc='Terminal top-like monitor for icecream/icecc'
pkgname='icetop-git'
-pkgver=r37.48482f3
+pkgver=r41.e782c8c
pkgrel=1
license=('GPL2')
arch=('x86_64' 'i686')
-depends=('icecream' 'libdill' 'libtickit-bzr')
-makedepends=('meson' 'ninja')
+depends=('icecream' 'libdill' 'libtickit')
+makedepends=('meson' 'ninja' 'git')
url='https://github.com/aperezdc/icetop'
source=("${pkgname}::git+${url}")
sha512sums=("SKIP")
@@ -22,7 +22,7 @@ pkgver () {
build () {
cd "${pkgname}"
- meson --buildtype release --prefix /usr build
+ arch-meson build
ninja -C build
}