summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Brost2019-10-08 20:05:46 +0200
committerJulian Brost2019-10-08 20:05:46 +0200
commit5ae965d6c616d9328654012256fddbdbcf33c431 (patch)
treebe18e09122ad7fa4c8918575af8a953778ddf181
parent9882815d89baa800a3d71835ae388361e270468d (diff)
downloadaur-5ae965d6c616d9328654012256fddbdbcf33c431.tar.gz
add workaround for boost version not being detected correctly
There is a problem with CMake>=3.15 and Boost>=1.70.0 where the value of a variable containing the boost version changed, for more details see https://github.com/Icinga/icinga2/issues/7566
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50eb5f51e99f..e34329860dea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = icinga2-git
pkgdesc = An open source host, service and network monitoring program
- pkgver = 2.10.3.r292.ge2df11520
+ pkgver = 2.11.0.r23.g06296175e
pkgrel = 1
url = http://www.icinga.org
install = icinga2-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 154230fd489c..f15650fd9e20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='icinga2-git'
_pkgname=icinga2
-pkgver=2.10.3.r292.ge2df11520
+pkgver=2.11.0.r23.g06296175e
pkgrel=1
pkgdesc="An open source host, service and network monitoring program"
license=('GPL')
@@ -59,6 +59,9 @@ build() {
mkdir -p "$srcdir/$_pkgname/build"
cd "$srcdir/$_pkgname/build"
+ # The four lines settings variables regarding boost are a workaround for the
+ # boost version not being detected properly, see also
+ # https://github.com/Icinga/icinga2/issues/7566
cmake "$srcdir/$_pkgname" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_SYSCONFDIR=/etc \
@@ -69,7 +72,12 @@ build() {
-DICINGA2_SYSCONFIGFILE=/etc/default/icinga2 \
-DICINGA2_PLUGINDIR=/usr/lib/monitoring-plugins \
-DUSE_SYSTEMD=ON \
- -DLOGROTATE_HAS_SU=OFF
+ -DLOGROTATE_HAS_SU=OFF \
+ -DBoost_NO_BOOST_CMAKE=TRUE \
+ -DBoost_NO_SYSTEM_PATHS=TRUE \
+ -DBOOST_LIBRARYDIR=/usr/lib \
+ -DBOOST_INCLUDEDIR=/usr/include
+
make
}