summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNahuel Gomez Castro2020-01-17 12:38:06 -0300
committerNahuel Gomez Castro2020-01-17 12:38:06 -0300
commitb9317d9dd387cf6742e49606921e9a244bde8a2d (patch)
tree80f15accc94989a41f5b6cc0e01edce96c13e6ad
downloadaur-b9317d9dd387cf6742e49606921e9a244bde8a2d.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--CHANGELOG4
-rw-r--r--PKGBUILD28
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27dbf0909913
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = icon-library
+ pkgdesc = Symbolic icons for your apps
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://gitlab.gnome.org/World/design/icon-library
+ changelog = CHANGELOG
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ makedepends = meson
+ makedepends = git
+ depends = libhandy
+ depends = gdk-pixbuf2
+ source = git+https://gitlab.gnome.org/World/design/icon-library.git#tag=0.0.4
+ sha256sums = SKIP
+
+pkgname = icon-library
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c30f9673303f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/icon-library
+/pkg
+/src
+*.tar.xz
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..27128452f77c
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,4 @@
+v0.0.4
+======
+- Update the icons.
+- Translations updates
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c58ed431103
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Nahuel Gomez Castro <nahual_gomca@outlook.com.ar>
+
+pkgname='icon-library'
+pkgver='0.0.4'
+pkgrel='1'
+pkgdesc="Symbolic icons for your apps"
+changelog='CHANGELOG'
+arch=('x86_64')
+url="https://gitlab.gnome.org/World/design/${pkgname}"
+license=('GPL3')
+depends=('libhandy' 'gdk-pixbuf2')
+makedepends=('rust' 'meson' 'git')
+source=("git+${url}.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+pkgver () {
+ cd ${pkgname}
+ git describe --tags | sed 's/-/.r/; s/-/./'
+}
+
+build () {
+ arch-meson ${pkgname} build
+ ninja -C build
+}
+
+package () {
+ DESTDIR="${pkgdir}" ninja -C build install
+}