summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-11-05 13:58:39 +0800
committerChocobo12017-11-05 14:30:27 +0800
commit8238402be8f0bfcf8169cc39598c52455df52f04 (patch)
treed23fc21df1b986f5b849f1d414d0994062910b2d
downloadaur-icu-svn.tar.gz
newpkg: icu-svn r40666-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fca537d43d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = icu-svn
+ pkgdesc = International Components for Unicode library
+ pkgver = r40666
+ pkgrel = 1
+ url = http://site.icu-project.org/
+ arch = i686
+ arch = x86_64
+ license = custom:icu
+ makedepends = subversion
+ depends = glibc
+ depends = sh
+ provides = icu
+ conflicts = icu
+ source = svn+http://source.icu-project.org/repos/icu/trunk/icu4c
+ sha256sums = SKIP
+
+pkgname = icu-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1975e3183d32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=icu-svn
+pkgver=r40666
+pkgrel=1
+pkgdesc="International Components for Unicode library"
+arch=('i686' 'x86_64')
+url="http://site.icu-project.org/"
+license=('custom:icu')
+depends=('glibc' 'sh')
+makedepends=('subversion')
+provides=('icu')
+conflicts=('icu')
+source=("svn+http://source.icu-project.org/repos/icu/trunk/icu4c")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "icu4c"
+
+ _ver="$(svnversion)"
+ printf "r%s" "${_ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "icu4c/source"
+
+ ./configure --prefix="/usr" --sbindir="/usr/bin" --sysconfdir="/etc"
+ make
+}
+
+check() {
+ cd "icu4c/source"
+
+ make check
+}
+
+package() {
+ cd "icu4c/source"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/icu4c/LICENSE" "$pkgdir/usr/share/licenses/icu/LICENSE"
+}