summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchort2022-11-22 14:56:11 +0500
committerchort2022-11-22 14:56:11 +0500
commite666b97e1191c435285d570e2b279dfc6cd1400f (patch)
tree16376939e6f58231ffa8171ad48bd3db1c53b053
parent0fe2c97ce753bd4f414dad01a3e73ee95e832c9c (diff)
downloadaur-ido.tar.gz
version 1.0
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
2 files changed, 35 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1f844694a99..cd8b8e712f7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,23 @@
pkgbase = ido
- pkgdesc = Widgets and other objects used for indicators
- pkgver = 12.10.2
- pkgrel = 4
+ pkgdesc = Widgets and other objects used for indicators by the Unity7 user interface
+ pkgver = 13.10.0.22.10.20221007
+ pkgrel = 1
url = https://launchpad.net/ido
- arch = i686
arch = x86_64
- license = LGPL
- depends = gtk3
- source = https://launchpad.net/ido/12.10/12.10.2/+download/ido-12.10.2.tar.gz
- sha256sums = e2279c7c0eeeb2e038eaf87418df109327de28c758f45e72e19c7154a1f71f00
+ license = GPL
+ makedepends = gnome-common
+ makedepends = pkgconf
+ makedepends = glibc
+ makedepends = glib2
+ makedepends = vala
+ depends = libxi
+ depends = libx11
+ depends = gobject-introspection
+ depends = pango
+ depends = gdk-pixbuf2
+ depends = cairo
+ depends = gtk3-ubuntu
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/ido_13.10.0+22.10.20221007.orig.tar.gz
+ sha512sums = SKIP
pkgname = ido
-
diff --git a/PKGBUILD b/PKGBUILD
index e79c975ccecc..46867c7c34f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,24 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
-# Contributor: Balló György <ballogyor+arch@gmail.com>
+# Maintainer: Xinc
pkgname=ido
-pkgver=12.10.2
-pkgrel=4
-pkgdesc='Widgets and other objects used for indicators'
-arch=('i686' 'x86_64')
-url='https://launchpad.net/ido'
-license=('LGPL')
-depends=('gtk3')
-source=("https://launchpad.net/ido/${pkgver%.*}/${pkgver}/+download/ido-${pkgver}.tar.gz")
-sha256sums=('e2279c7c0eeeb2e038eaf87418df109327de28c758f45e72e19c7154a1f71f00')
+_actual_ver=13.10.0
+_extra_ver=+22.10.20221007
+pkgver=${_actual_ver}${_extra_ver/\+/.}
+pkgrel=1
+pkgdesc="Widgets and other objects used for indicators by the Unity7 user interface"
+arch=(x86_64)
+url="https://launchpad.net/ido"
+license=(GPL)
+depends=(libxi libx11 gobject-introspection pango gdk-pixbuf2 cairo gtk3-ubuntu)
+makedepends=(gnome-common pkgconf glibc glib2 vala)
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/ido_${_actual_ver}${_extra_ver}.orig.tar.gz")
+sha512sums=('SKIP')
build() {
- cd ido-${pkgver}
-
- export CFLAGS="$CFLAGS -Wno-deprecated-declarations"
-
- ./configure \
- --prefix='/usr' \
- --localstatedir='/var' \
- --sysconfdir='/etc'
- make
+ ./autogen.sh --prefix=/usr --libexecdir=/usr/lib/"${pkgname}" --disable-static --disable-introspection
+ make
}
-package(){
- cd ido-${pkgver}
-
- make DESTDIR="${pkgdir}" install
+package() {
+ make DESTDIR="${pkgdir}" -j1 install
}
-
-# vim: ts=2 sw=2 et: