summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics@felics-tablet2016-09-04 15:16:12 +0200
committerfelics@felics-tablet2016-09-04 15:16:12 +0200
commiteb1df9ac34e361da85ab7b8221a6333b285eb172 (patch)
tree4acb59098026e5664c11b60f504c6449cf8ab2b3
parent2cfda65ecd5750161ca1745d42c7721c23e3866b (diff)
downloadaur-eb1df9ac34e361da85ab7b8221a6333b285eb172.tar.gz
Changed pkgver to something more sensible. change provides. Changed conflicts.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dcef410b257..d8b2788e6349 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = idos-timetable-browser-license-installer-latest
pkgdesc = If you purchased IDOS for Windows by CHAPS, then this installs the license. You need to enter your ZIP-extraction-code and your setup-code during installation. Runs an interactive GUI software via wine during installation.
- pkgver = 2016_7_1
- pkgrel = 3
- epoch = 0
+ pkgver = 2015_2016
+ pkgrel = 1
+ epoch = 1
url = http://www.chaps.cz/eng/download/idos-install/
arch = i686
arch = x86_64
@@ -11,11 +11,11 @@ pkgbase = idos-timetable-browser-license-installer-latest
makedepends = unzip
makedepends = wine
depends = idos-timetable-browser
- provides = idos-timetable-browser-license-installer=2016_7_1
- provides = idos-timetable-browser-license=2016_7_1
- provides = idos-for-windows=2016_7_1
+ provides = idos-timetable-browser-license-installer=2015_2016
+ provides = idos-timetable-browser-license=2015_2016
conflicts = idos-timetable-browser-license-installer
- replaces = idos-timetable-browser-license-installer<=2016_7_1
+ conflicts = idos-timetable-browser-license
+ replaces = idos-timetable-browser-license-installer<=2015_2016
source = iwin.zip::ftp://ttakt.chaps.cz/TTAktual/Win/Zip/IWIN.ZIP
source = IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf
source = copying.txt
diff --git a/PKGBUILD b/PKGBUILD
index 6a86bdebb580..fd250a0d47fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
_pkgname=idos-timetable-browser-license-installer
pkgname="${_pkgname}-latest"
-epoch=0
-pkgver=2016_7_1
-pkgrel=3
+epoch=1
+_pkgver=2015_2016
+pkgver=2015_2016
+pkgrel=1
pkgdesc="If you purchased IDOS for Windows by CHAPS, then this installs the license. You need to enter your ZIP-extraction-code and your setup-code during installation. Runs an interactive GUI software via wine during installation."
arch=('i686' 'x86_64')
url="http://www.chaps.cz/eng/download/idos-install/"
@@ -28,10 +29,12 @@ optdepends=()
provides=(
"${_pkgname}=${pkgver}"
"idos-timetable-browser-license=${pkgver}"
- "idos-for-windows=${pkgver}"
)
-conflicts=("${_pkgname}")
+conflicts=(
+ "${_pkgname}"
+ "idos-timetable-browser-license"
+)
replaces=("${_pkgname}<=${pkgver}")
@@ -52,7 +55,12 @@ sha256sums=(
pkgver() {
- wget -nv -O- "http://www.chaps.cz/eng/download/idos-install/zip" | grep 'Update date\:' | cut -d, -f1 | sed -r 's|([0-9]+)\.([0-9]+)\.([0-9]+).|\n\3_\2_\1\n|g' | grep -E '^[0-9]+_[0-9]+_[0-9]+'
+ ### We do not get the version of the installer, since we only use the license file.
+ ### We use the version of the timetable year.
+
+ echo "${_pkgver}"
+
+ # wget -nv -O- "http://www.chaps.cz/eng/download/idos-install/zip" | grep 'Update date\:' | cut -d, -f1 | sed -r 's|([0-9]+)\.([0-9]+)\.([0-9]+).|\n\3_\2_\1\n|g' | grep -E '^[0-9]+_[0-9]+_[0-9]+'
}