summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormb642021-09-20 22:16:30 -0700
committermb642021-09-20 22:16:30 -0700
commit49e6bf32e83e214894ca3d9c4547361e06d2bb7a (patch)
tree71ed444c919b3a0ceca5b22f5fb0f3123d58fba9
parentb109b76b9e133d7acdb2397ba172e70686298fab (diff)
downloadaur-49e6bf32e83e214894ca3d9c4547361e06d2bb7a.tar.gz
Update for changes as of version 0.5.1
This adds the test and idris2-api packages to the install, as well as including their source code, with the goal of supporting the new LSP server out of the box. It works with the code in this PR: <https://github.com/idris-community/idris2-lsp/pull/96> It also includes the new Bash completions.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4129c82f4ba6..57bf935c5131 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = idris2-git
pkgdesc = Funtional Programming Lanugage with Dependent Types
- pkgver = 0.3.0.r154.g37a4c6f1
+ pkgver = 0.5.1.r2.ga0846af5
pkgrel = 1
url = https://www.idris-lang.org/
arch = x86_64
@@ -13,4 +13,3 @@ pkgbase = idris2-git
md5sums = SKIP
pkgname = idris2-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 914769469124..f68a455a3a83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
#
pkgname=idris2-git
-pkgver=0.3.0.r154.g37a4c6f1
+pkgver=0.5.1.r2.ga0846af5
pkgrel=1
pkgdesc="Funtional Programming Lanugage with Dependent Types"
url="https://www.idris-lang.org/"
@@ -48,15 +48,23 @@ package() {
unset MAKEFLAGS
export SCHEME=scheme
+ # Install compiler and runtime
PREFIX="$pkgdir/usr/lib" make install-idris2
PREFIX="$pkgdir/usr/lib" make install-support
- for lib in prelude base contrib network ; do
- cd libs/$lib
- IDRIS2_PREFIX="$pkgdir/usr/lib" ../../build/exec/idris2 --install $lib.ipkg
- cd ../..
+
+ IDRIS2_BINARY="$srcdir/$_srcname/build/exec/idris2"
+
+ # Install libraries
+ install_lib() {
+ IDRIS2_PREFIX="$pkgdir/usr/lib" \
+ "$IDRIS2_BINARY" --install-with-src $1.ipkg
+ }
+ for lib in prelude base contrib network test ; do
+ ( cd libs/$lib ; install_lib $lib )
done
+ install_lib idris2api
- # clean up install
+ # Clean up install
mkdir -p "$pkgdir/usr/bin"
mv "$pkgdir/usr/lib/bin/idris2_app/idris2.so" "$pkgdir/usr/bin/idris2"
rm -r "$pkgdir/usr/lib/bin"
@@ -66,5 +74,7 @@ package() {
# Fix permissions
find "$pkgdir" -type d -exec chmod 755 {} \;
+ install -Dm644 <("$IDRIS2_BINARY" --bash-completion-script idris2) \
+ "$pkgdir/usr/share/bash-completion/completions/idris2"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}