aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Kolchenko2020-11-23 17:32:08 +0300
committerAndrey Kolchenko2020-11-23 17:32:08 +0300
commit99d09dbbacfbf81d7b0d73bfb71e162c4b48fc94 (patch)
tree857ce66d528619439b6ac1d3bb7db08c06749ce5
parent62efe9eb1941699c237fc0d5f855ac2da940962d (diff)
downloadaur-99d09dbbacfbf81d7b0d73bfb71e162c4b48fc94.tar.gz
Bump new version of ifcplugin with config fixes
-rw-r--r--PKGBUILD47
-rw-r--r--ifcplugin.install2
2 files changed, 19 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb5769ce7035..fd4aef8c2505 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,27 @@
-# Maintainer: Maxim Kraev <maxim.kraev@gmail.com>; Stepanov Aleksandr <sa@eri.su>
+# Contributor: Andrey Kolchenko <andrey@kolchenko.me>
pkgname=ifcplugin
-pkgver=3.0.7.0
-pkgrel=2
-_ubuntuver=raring
-_ubunturel=1
-pkgdesc="Crypto Interface Web Browser Plugin for https://gosuslugi.ru"
+pkgver=3.1.1.0
+pkgrel=1
+pkgdesc="Crypto Interface Web Browser Plugin for https://gosuslugi.ru/"
arch=('i686' 'x86_64')
-url="https://esia.gosuslugi.ru"
+url="https://ds-plugin.gosuslugi.ru/plugin/upload/Index.spr"
license=('unknown')
-depends=(pcsc-tools glibc acsccid)
-conflicts=()
+depends=("pcsc-tools" "glibc" "acsccid")
+install="ifcplugin.install"
-# 690ef5300f03eae34a76c3e0d424ca7bb857d4fe1dafd0b901a6a010b31f046f /home/eri/Downloads/IFCPlugin-i386.deb
-# 2f5736ea87c90833fb372ccc8d0f58795546cb08ee2663b53503f92778c206e4 /home/eri/Downloads/IFCPlugin-x86_64.deb
-# 090d81c342f04104cf9a9678b98010f70abc311098d5c3f3e7d3572c3c15afe0fcedfe9ef5be46158182748ec27d3f1a6d5e26e54af9fce19cfcc04c29025239 /home/eri/Downloads/IFCPlugin-i386.deb
-# c89fef2c82903baa7b6d9bd9df2beefa844427db709a4a9ddd97184cfffd2ba18a0df3ead7cfcb14cb3d234cc7cf78197b75759a95a127162d199e8689f24d94 /home/eri/Downloads/IFCPlugin-x86_64.deb
-
-
-if [[ "$CARCH" == "i686" ]]; then
- source=("https://ds-plugin.gosuslugi.ru/plugin/htdocs/plugin/IFCPlugin-i386.deb")
- sha512sums=('090d81c342f04104cf9a9678b98010f70abc311098d5c3f3e7d3572c3c15afe0fcedfe9ef5be46158182748ec27d3f1a6d5e26e54af9fce19cfcc04c29025239')
-else
- source=("https://ds-plugin.gosuslugi.ru/plugin/htdocs/plugin/IFCPlugin-x86_64.deb")
- sha512sums=('c89fef2c82903baa7b6d9bd9df2beefa844427db709a4a9ddd97184cfffd2ba18a0df3ead7cfcb14cb3d234cc7cf78197b75759a95a127162d199e8689f24d94')
-fi
-install=ifcplugin.install
+source_x86_64=("$pkgname-$pkgver.rpm::https://ds-plugin.gosuslugi.ru/plugin/upload/assets/distrib/IFCPlugin-x86_64.rpm")
+sha256sums_x86_64=("7fa0df9cda6c0b2352d5cf1530289cc8fe93e961f9f135178cef12aa8ad19957")
+source_i686=("$pkgname-$pkgver.rpm::https://ds-plugin.gosuslugi.ru/plugin/upload/assets/distrib/IFCPlugin-i386.rpm")
+sha256sums_i686=("92c9253417a01bbb143fdb34448febf6e264b6b7d64aad3b47e3ece8bd181d57")
package() {
- cd "$srcdir"
- bsdtar -xf data.tar.xz -C "$pkgdir"
-
- sed -i "s/ifd-ccid.bundle/ifd-acsccid.bundle/g" $pkgdir/etc/update_ccid_boundle/update_ccid_boundle.sh
-
+ cp -r "$srcdir/etc/" "$pkgdir/etc"
+ cp -r "$srcdir/usr/" "$pkgdir/usr"
+ cp -r "$srcdir/opt/" "$pkgdir/opt"
mkdir -p $pkgdir/var/log/ifc
mkdir -p $pkgdir/var/log/ifc/engine_logs
- chmod 777 $pkgdir/var/log/ifc
- chmod 777 $pkgdir/var/log/ifc/engine_logs
+
+ sed -i "s/ifd-ccid.bundle/ifd-acsccid.bundle/g" "$pkgdir/etc/update_ccid_boundle/update_ccid_boundle.sh"
+ wget -O "$srcdir/etc/ifc.cfg" https://www.cryptopro.ru/sites/default/files/public/faq/ifcx64.cfg
}
diff --git a/ifcplugin.install b/ifcplugin.install
index 0e22397259f2..bdadddab4c02 100644
--- a/ifcplugin.install
+++ b/ifcplugin.install
@@ -1,5 +1,6 @@
post_install() {
+ ln -s "/etc/opt/chrome/native-messaging-hosts/ru.rtlabs.ifcplugin.json" "/etc/chromium/native-messaging-hosts"
# Add VIDs and PIDs to CCID Boundle
cd /etc/update_ccid_boundle
bash ./update_ccid_boundle.sh
@@ -7,6 +8,7 @@ post_install() {
post_upgrade() {
+ ln -s "/etc/opt/chrome/native-messaging-hosts/ru.rtlabs.ifcplugin.json" "/etc/chromium/native-messaging-hosts"
# Add VIDs and PIDs to CCID Boundle
cd /etc/update_ccid_boundle
bash ./update_ccid_boundle.sh