aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Kraev2015-06-24 14:50:40 +0300
committerMaxim Kraev2015-06-24 14:50:40 +0300
commitd79150bd231426f1919f0d3f0fea7e1c25936b53 (patch)
tree95994abf4a7ed409ae0b38fef09b3f88074693df
downloadaur-d79150bd231426f1919f0d3f0fea7e1c25936b53.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
-rw-r--r--README.md4
-rw-r--r--ifcplugin.install13
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c7fcb1becbb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ifcplugin
+ pkgdesc = Crypto Interface Web Browser Plugin for https://gosuslugi.ru
+ pkgver = 2.0.5.7
+ pkgrel = 4
+ url = https://esia.gosuslugi.ru
+ install = ifcplugin.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = pcsc-tools
+ depends = glibc
+ depends = acsccid
+ source = https://esia.gosuslugi.ru/sia-web/htdocs/plugin/IFCPlugin-x86_64.deb
+ sha512sums = 2bd547bea60c703018821942d8d496d4e36bf4e580ea517fa7ef7596faa4f944e7f31ce641ad5da21baad17ed82f5b373118860dd8a258b5cb7243ae36f3df3c
+
+pkgname = ifcplugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4aa196f4af88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Maxim Kraev <maxim.kraev@gmail.com>
+
+pkgname=ifcplugin
+pkgver=2.0.5.7
+pkgrel=4
+_ubuntuver=raring
+_ubunturel=4
+pkgdesc="Crypto Interface Web Browser Plugin for https://gosuslugi.ru"
+arch=('i686' 'x86_64')
+url="https://esia.gosuslugi.ru"
+license=('unknown')
+depends=(pcsc-tools glibc acsccid)
+conflicts=()
+if [[ "$CARCH" == "i686" ]]; then
+ source=("https://esia.gosuslugi.ru/sia-web/htdocs/plugin/IFCPlugin-i386.deb")
+ sha512sums=('c4c71c9bf081270f3381d1b3ba4b67d1d5c5755171e59ca59108058aa6e9645c34c81f14235da18712a4a04fd6a12abf110bc82b689a14f789afa354368fe8e9')
+else
+ source=("https://esia.gosuslugi.ru/sia-web/htdocs/plugin/IFCPlugin-x86_64.deb")
+ sha512sums=('2bd547bea60c703018821942d8d496d4e36bf4e580ea517fa7ef7596faa4f944e7f31ce641ad5da21baad17ed82f5b373118860dd8a258b5cb7243ae36f3df3c')
+fi
+install=ifcplugin.install
+
+package() {
+ cd "$srcdir"
+ bsdtar -xf data.tar.gz -C "$pkgdir"
+
+ sed -i "s/ifd-ccid.bundle/ifd-acsccid.bundle/g" $pkgdir/etc/update_ccid_boundle/update_ccid_boundle.sh
+
+ mkdir -p $pkgdir/var/log/ifc
+ mkdir -p $pkgdir/var/log/ifc/engine_logs
+ chmod 777 $pkgdir/var/log/ifc
+ chmod 777 $pkgdir/var/log/ifc/engine_logs
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..966bdda3c54a
--- /dev/null
+++ b/README.md
@@ -0,0 +1,4 @@
+aur-ifcplugin
+=============
+
+aur ifcplugin package
diff --git a/ifcplugin.install b/ifcplugin.install
new file mode 100644
index 000000000000..0e22397259f2
--- /dev/null
+++ b/ifcplugin.install
@@ -0,0 +1,13 @@
+
+post_install() {
+ # Add VIDs and PIDs to CCID Boundle
+ cd /etc/update_ccid_boundle
+ bash ./update_ccid_boundle.sh
+}
+
+
+post_upgrade() {
+ # Add VIDs and PIDs to CCID Boundle
+ cd /etc/update_ccid_boundle
+ bash ./update_ccid_boundle.sh
+}