summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZitro2021-10-25 01:57:27 +0300
committerZitro2021-10-25 01:57:27 +0300
commitf88cfb5879bce8a588c66c4830a6322a0f4d93f5 (patch)
tree200bd851780774a02c08be7587b0d2566f44ef05
downloadaur-ifodump.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
-rw-r--r--dvdread.patch37
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94deb212efa3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ifodump
+ pkgdesc = Dump iFO data from dvd disk
+ pkgver = 0.0.1
+ pkgrel = 0
+ url = https://sourceforge.net/projects/dvd/files/ifodump
+ arch = any
+ license = GPL2
+ depends = libdvdread
+ source = https://downloads.sourceforge.net/project/dvd/ifodump/ifodump/ifodump-0.0.1.tar.gz
+ source = dvdread.patch
+ sha256sums = 83c4cdedee0a0f4fd15aa319b317b94cbc8cd71fd756ce3baeaee9818b1faa41
+ sha256sums = 4efb985aebb813e701bcc28ede3a96f823474d4f54a1443ac55f78666f407b5f
+
+pkgname = ifodump
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..44d095199eb9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.zst
+*.tar.gz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6dc9a6704dcb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Zitro <com dot proton mail at u4595650016>
+
+pkgname=ifodump
+pkgdesc="Dump iFO data from dvd disk"
+pkgver=0.0.1
+pkgrel=0
+depends=("libdvdread")
+
+url="https://sourceforge.net/projects/dvd/files/ifodump"
+source=("https://downloads.sourceforge.net/project/dvd/ifodump/ifodump/ifodump-0.0.1.tar.gz" "dvdread.patch")
+sha256sums=(
+ "83c4cdedee0a0f4fd15aa319b317b94cbc8cd71fd756ce3baeaee9818b1faa41"
+ "4efb985aebb813e701bcc28ede3a96f823474d4f54a1443ac55f78666f407b5f"
+)
+
+license=("GPL2")
+arch=(any)
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p1 -i ../dvdread.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./autogen.sh
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
diff --git a/dvdread.patch b/dvdread.patch
new file mode 100644
index 000000000000..fb7cb6d842bf
--- /dev/null
+++ b/dvdread.patch
@@ -0,0 +1,37 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 965d913..10d1a4a 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -6,5 +6,5 @@
+ bin_PROGRAMS = ifo_dump
+
+ ifo_dump_SOURCES = ifo_dump.c
+-ifo_dump_LDADD = -ldvdnav @DL_LIBS@
++ifo_dump_LDADD = -ldvdread @DL_LIBS@
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 76c0174..3d32c2a 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -101,7 +101,7 @@ install_sh = @install_sh@
+ bin_PROGRAMS = ifo_dump
+
+ ifo_dump_SOURCES = ifo_dump.c
+-ifo_dump_LDADD = -ldvdnav @DL_LIBS@
++ifo_dump_LDADD = -ldvdread @DL_LIBS@
+ subdir = src
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = $(top_builddir)/config.h
+diff --git a/src/ifo_dump.c b/src/ifo_dump.c
+index 6a48d59..dba34f2 100644
+--- a/src/ifo_dump.c
++++ b/src/ifo_dump.c
+@@ -26,7 +26,7 @@
+ #include <getopt.h>
+ #endif
+
+-#include <dvdnav/ifo_print.h>
++#include <dvdread/ifo_print.h>
+
+ static char *program_name;
+