summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrockybulwinkle2022-11-08 12:37:16 -0600
committerrockybulwinkle2022-11-08 12:37:16 -0600
commit1d77788b3c23e176ed95469318f4dd779061df84 (patch)
tree0826458811de12040fd4d49e1fdbb40c830d13c6
parentdd3d8753f96ae3f563f96e2371e7aba979fa527b (diff)
downloadaur-1d77788b3c23e176ed95469318f4dd779061df84.tar.gz
Work around compilation issues. Update metadata.
Compilation was failing due to a const being cast to non-const. Added -fpermissive to the compilaton flags to work around. Updated metadata: bumped pkgrel, added missing ncurses dependency.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 586cc3fed4f5..b6aa26151139 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
pkgbase = ike
pkgdesc = Shrew Soft VPN client for Linux
pkgver = 2.2.1
- pkgrel = 6
+ pkgrel = 7
url = http://www.shrew.net
arch = i686
arch = x86_64
license = BSD
makedepends = cmake
depends = openssl
+ depends = ncurses
depends = libedit
optdepends = openldap
backup = etc/iked.conf
source = http://www.shrew.net/download/ike/ike-2.2.1-release.tgz
source = iked.service
source = openssl-1.1.0.patch
+ source = cmake-threadlib.patch
md5sums = 3dac18a2da5809ccb38c50cd4a455897
md5sums = 3cb3ff3b663805f76be1efd527ae436c
md5sums = 57348fe9112555c0204709c1716e5fff
+ md5sums = 4c823bae9e006cf7bfb11fa633a59837
pkgname = ike
-
diff --git a/PKGBUILD b/PKGBUILD
index 67236e916076..31b350eb1b51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
pkgname=ike
pkgver=2.2.1
-pkgrel=6
+pkgrel=7
pkgdesc='Shrew Soft VPN client for Linux'
arch=(i686 x86_64)
url='http://www.shrew.net'
license=(BSD)
-depends=(openssl libedit)
+depends=(openssl ncurses libedit)
makedepends=(cmake)
optdepends=(openldap)
backup=(etc/iked.conf)
@@ -30,7 +30,7 @@ prepare () {
build () {
cd "$srcdir/ike"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DQTGUI=NO -DETCDIR=/etc -DNATT=YES \
+ CXXFLAGS="-fpermissive" CFLAGS="-fpermissive" cmake -DCMAKE_INSTALL_PREFIX=/usr -DQTGUI=NO -DETCDIR=/etc -DNATT=YES \
-DMANDIR=/usr/share/man -DSBINDIR=/usr/bin
make
}